WordPress.org

Ready to get started?Download WordPress

Forums

My Calendar
Event Details Not Showing (4 posts)

  1. cpengilly
    Member
    Posted 1 year ago #

    Hi,

    I am running a WP Multisite and I run the MyCalendar plugin on 3 of the 4 sites. The site I am inquiring about is http://www.cynthiapengilly.com/1101/schedule/ and it is running the BrightPage theme. There are a few events under January 2013 for testing purposes.

    Okay, here's the deal. Within MyCalendar Settings, I am using the light.css style. Whenever, I use any of the MyCalendar built-in styles, the plugin works right up until you click on the details of the event - then I only see the title of the event *without* the details. However, when I disable the mycalendar style sheet (using the checkbox provided in Style Editor), the event details all show up perfectly fine. The problem is this: I do not want to suppress the mycalendar style sheet because it renders the calendar information in a much more user-friendly way than the style sheet affiliated with the BrightPage Template. I am comfortable going in and modifying the code - either CSS or PHP - if I know what I need to change.

    I can't, for the life of me, figure out why this has anything to do with the style sheets, but that is the only thing that I changed (and I've tested it all day) - one option makes the event details show and the other does not. Any suggestions or thoughts?

    Cynthia

    http://wordpress.org/extend/plugins/my-calendar/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    It looks to me like the behaviors for the list style sheet aren't enabled - if you go the My Calendar Behavior Editor page, scroll down to the 'list' javascripts, and enable them, this should be more clear.

    The details are definitely present, as I can see in the source of the page.

    This is still not really quite right - when the list Javascript is disabled, the event details should just always be visible - I'll need to explore that further.

  3. cpengilly
    Member
    Posted 1 year ago #

    The event details still aren't showing, after enabling the JavaScript list on Calendar Behavior Editor page. If I disable the MyCalendar style sheet, then all the details show up as they should BUT I then lose all the pretty formatting.

  4. cpengilly
    Member
    Posted 1 year ago #

    I fixed it myself. 1) I disabled the MyCalendar Style Sheet, 2) copy/pasted the MyCalendar css information from the theme that I liked over to the style.css page for my WordPress Theme (BrightPage), 3) I used a Firefox plug-in to help me identify which classes were being called and then I modified the copied css code to call up the correct classes. It's not perfect, but it works (and looks) better than before.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.