WordPress.org

Ready to get started?Download WordPress

Forums

Ajax Event Calendar
event calender (51 posts)

  1. nissenisse
    Member
    Posted 11 months ago #

    ned help the event calender 1,0,4 is broken...
    I can not add events and can not change events, etc. in the new Version 1.0.4

    http://wordpress.org/plugins/ajax-event-calendar/

  2. DrBobber
    Member
    Posted 11 months ago #

    I am also having the same syptoms. It started occuring when I upgraded to WordPress 3.6

    This is the error I am getting when trying to edit, add, change or view any event:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; compat/4.2.08050; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; 98770040903; Engine/6.08050)
    Timestamp: Sun, 4 Aug 2013 16:57:43 UTC

    Message: Not implemented

    Line: 16
    Char: 133
    Code: 0
    URI: http://www.southlaketroop937.org/wp-content/plugins/ajax-event-calendar/js/jquery.simplemodal.1.4.3.min.js?ver=1.4.3

  3. johnsonjt50
    Member
    Posted 11 months ago #

    Hi,

    I have the same problem. After updating to WP 3.6, it is no longer possible to add/edit events.

    This happens only in Internet Explorer 8, 9, 10
    It works well in Chrome and FireFox.

    Are there any suggestions?

    Thanks for your help!

  4. jlihle483
    Member
    Posted 11 months ago #

    Same problem here - Works great in Firefox. Perhaps there are some settings in IE that can be made? Thanks.

  5. Ben Kaeding
    Member
    Posted 11 months ago #

    Any updates on this issue yet? I updated WordPress to 3.6 as well before checking compatibility. :(

  6. johnsonjt50
    Member
    Posted 11 months ago #

    I checked on my test-site, but only with chrome :(

    Is there an easy solution to this problem? Could it be a problem with jQuery in WP 3.6?

  7. william_kowalski
    Member
    Posted 11 months ago #

    Same problem.

  8. Ben Kaeding
    Member
    Posted 11 months ago #

    I was able to get Calendar working after including the jquery-migrate-1.2.1.min.js in my theme. It allows old jquery functionality to work.

  9. jlihle483
    Member
    Posted 11 months ago #

    This might be the answer but sorry - I don't know how to install. I'm using the Magazine Basic Theme. It's described as a Plugin but cannot find in the Add New section. I found it on the GitHub site BUT - Could you advise on how to install or link me to a place that will tell me? Thanks.

  10. Ben Kaeding
    Member
    Posted 11 months ago #

    I had to use a modified version of the SimpleModal js file to correct the IE issues as well. You can download it here from my site: http://www.benkaeding.com/jquery.simplemodal.js

  11. jlihle483
    Member
    Posted 11 months ago #

    Sorry but your link gives me a "server not found error. I'm not familiar with jQuery programing (code). If I'm able to download, how difficult will it be to install? Thanks.

  12. jlihle483
    Member
    Posted 11 months ago #

    Never mind - got it downloaded from your other post's link. Thanks.
    Where do I put it?

  13. johnsonjt50
    Member
    Posted 11 months ago #

    Hi,

    I changed the simplemodal.js, referenced it in the plugin and it works great in IE.

    Thanks to Ben Kaeding for providing the fixed js.

  14. jlihle483
    Member
    Posted 11 months ago #

    It works great in IE now! BUT now it doesn't show in FireFox. :(
    I didn't know if I'd get all the references so I renamed the SimpleModal I downloaded from Ben Kaeding and renamed it to jquery.simplemodal.1.4.3.min.js which was the name of the file in the Plugin's folder and overwrote the file (I saved the old file elsewhere just in case)
    Did I do something wrong? What should I have done. Thanks

  15. Ben Kaeding
    Member
    Posted 11 months ago #

    OK, so perfect storm... You need to read my comment earlier. WordPress is now using the most recent version of jquery. That means you must also include jquery-migrate-1.2.1.min.js the latest js lib that support all the functions that are no longer being supported. Go here to download to read and download the jquery plugin: https://github.com/jquery/jquery-migrate/ Add it to your website to support the most recent version of jquery with your old theme functions. Then deal with IE by replacing the SimpleModal js with the replacement I listed above. If you don't know how to edit the php or the js then simply replace the entire source of jquery.simplemodal.1.4.3.min.js in your plugin editor. Save a copy.... 'cause I ain't going to put it back if you break it.

  16. william_kowalski
    Member
    Posted 11 months ago #

    Ben (or anyone, really): I have replaced old js in the Simple Modal file with the new js. I've downloaded the jquery-migrate plugin as a zip file from github and attempted to install it as a plugin on my site. It won't install. Is this how it's meant to be installed?

  17. grouchyturtle
    Member
    Posted 11 months ago #

    Add me to the list. Can create new events or edit events. Tried in both Firefox and on Galaxy S3 with default browser.

  18. grouchyturtle
    Member
    Posted 11 months ago #

    Err...make that can't

  19. Ben Kaeding
    Member
    Posted 11 months ago #

    The jquery migrate plugin is just an add on for the jquery lib. You will need to upload the file to your server and reference/load it in your header or footer. It is not a wordpress plugin so it can't be installed like other plugins.

  20. Ben Kaeding
    Member
    Posted 11 months ago #

    function my_init() {
    	if (!is_admin()) {
    
    wp_register_script('jquery.migrate', 'http://code.jquery.com/jquery-migrate-1.2.1.js',, false, '1.2.1', true);
    		wp_enqueue_script('jquery.migrate');
    }

    I haven't tested this but using something like this to add the jquery migrate script in the footer should work as well. This would need to placed as code in a wordpress plugin or in the functions.php file in your theme.

    * don't mess with your functions.php unless you have both access to ftp and a copy before you change it. saving bad code in the functions.php will break your site.

  21. SCSnare
    Member
    Posted 11 months ago #

    Mine's broken now too. I can see the events that were already created, but if I try to edit them or if I try to add a new event, none of the buttons work (Cancel, Add, Delete, Update, or the 'X' to Close).

    Any ideas? I already added the two .js files to my site.

    I added this code to my theme's header.php

    <script src="<?php echo get_template_directory_uri(); ?>/js/jquery-migrate-1.2.1.min.js" type="text/javascript"></script>

    and this code to my admin-header.php after adding the migrate-1.2.1.min.js to the /js folder in the /wp-admin folder

    <script src="/js/jquery-migrate-1.2.1.min.js" type="text/javascript"></script>

  22. grouchyturtle
    Member
    Posted 11 months ago #

    Does anyone have suggestions on another calendar, that actually works in the latest version of WordPress?

    I've tried a few of these fixes and mine still isn't working. I need something that works now...as is. I'm just about ready to just create a simple list view calendar with plain text. At least I know upgrades won't break it!

  23. william_kowalski
    Member
    Posted 11 months ago #

    This plugin still works in every other browser besides Internet Explorer. I have not played around further with any code. I'm just waiting for an update and in the meantime advising my client to use Chrome. Works fine.

  24. grouchyturtle
    Member
    Posted 11 months ago #

    Not for me. Mine no longer even displays in Firefox.

  25. jlihle483
    Member
    Posted 11 months ago #

    I changed the Simplemodal and got it to work in IE but not Firefox. When I tried adding the migrate fix...
    The first attempt crashed the site. I backed that out and tried a couple other suggestions, which didn't work. I'm assuming I don't know how to install.
    I backed all my attempts out and reinstalled the simplemodel and am leaving it for an upgrade from Mr. Miller. At least the calendar will work for 95% of the site's demographic.
    A post from the Mr. Miller saying an upgrade is on the way, would probably keep me from getting panicky and crashing my site again. :)

  26. grouchyturtle
    Member
    Posted 11 months ago #

    Mr. Miller seems pretty slow to respond, and I don't remember the last time there was and update, so I'm not holding my breath for this to be resolved anytime soon. No response to the thread on google yet, either.

    I think I'm making the switch to WP Calendar. Not as nice Ajax Event calendar, but it displays almost the same (a little simpler even). Going to take a little bit of work to get categories color coded...unless I decide I can just live without that, but at least it works.

  27. givesuccess
    Member
    Posted 11 months ago #

    If there is a fix in this thread somewhere can it be exlpianed better? Like where to put what files and exactly where to dl what files? Please, bc I am confused trying to follow how to fix or try to fix this.

    where to put - jquery.simplemodal.js? amd son errors sai the min.js version that is not found anywhere?

    Where to put - jquery-1.9.0.js and jquery-migrate-1.2.1.js. Also where and how to put in theme? What dir do they go into? Wp-admin, wp-includes, the theme dir???where??
    or... call from another site like in the read me file - :

    <script src="http://code.jquery.com/jquery-1.9.0.js"></script>
    <script src="http://code.jquery.com/jquery-migrate-1.2.1.js"></script>

    I have ben trying all diff ways and no luck. If anyything it got worse bc now it dont work in FF or opers . Was only IE 8 b4? Cant even undo things bc it still wont come back now

    Very confusing. wish the creator would fix and put in update soon bc several clients use and need this to work and I hate not being able to fix or give timeframe as to when I will have fixed.

  28. Carol
    Member
    Posted 11 months ago #

    I am having the same issue givesuccess. I copied and pasted the code from jquery.simplemodal.1.4.4.min.js to jquery.simplemodal.1.4.3.min.js and the result was that it didn't work in any browser. Before doing that change it was working in all browsers except for IE.

    I was able to reverse that change and my site is working in everything except for IE again.

    Can someone please give clearer instructions on all the items that need to be changed? I would greatly appreciate that and I would just die of overwhelming joy if the developer would post an update. :)

    This is an awesome calendar and the company that I have using it loves it but we need it to work in IE.

  29. givesuccess
    Member
    Posted 11 months ago #

    Ok after another attemp i got to work.

    I just replaced jquery.simplemodal.js

    1)I downloaded from like above by right cliking and "saving as".

    2) in this dir - wp-content/plugins/ajax-event-calendar/js/ I renamed the original file to "orig-jquery.simplemodal.1.4.3.min.js" to keep as back up. Then ftp-ed in the fixed file to this same dir.

    3) i renamed th downloaded (fixed) file it to this: --> jquery.simplemodal.1.4.3.min.js (the orig file name)

    Now it works again on IE FF and opera!

    I hope this makes it easier to follow and I also hope it works of reveryone. I did not mess with adding the "github.com/jquery/jquery-migrate/" stuff at all.

    Goodluck all

    the site I fixed on is http://jimmypritchard.com/ if u want to check it out to see it fixed.

  30. grouchyturtle
    Member
    Posted 10 months ago #

    givesuccess - did you actually try editing or adding new events after replacing the file. Or did it just fix display issues.

    I just gave it a shot, and my calendar displays, but I still can't edit, delete, add new events, and the time fields are still missing.

Reply »

You must log in to post.

About this Plugin

About this Topic