WordPress.org

Ready to get started?Download WordPress

Forums

EU privacy law / email verification / database timing (5 posts)

  1. BeautyPirate
    Member
    Posted 1 year ago #

    Hello everybody,

    In order to comply to the european privacy act, I am willing to only create a user account when the email address entered during the signup
    process (public subscribers) has been verified.

    WordPress however goes tips up when I try to use any plugin for this.

    Does someone have a script that does this (or tell me how to write one as I am obviously too stupid to do it...)

    - Email Address is taken from signup process
    - Individual activation link is generated and sent out to that address
    - User has ie. 14 days to hit that link or the account will be deleted automatically
    - WordPress automatic welcome mail with password must only be sent out once the email address has been verified and the account was finally saved.

    Now, how can that be done?

  2. leejosepho
    Member
    Posted 1 year ago #

    User has ie. 14 days to hit that link or the account will be deleted automatically

    I do not know about that part, but my installation already does at least the rest of what you are asking about.

  3. BeautyPirate
    Member
    Posted 1 year ago #

    What version are you on? o.O

    When I register as a subscriber the password is emailed to me being the test user but there is no activation link sent, just a random password?

  4. leejosepho
    Member
    Posted 1 year ago #

    Oops, you are correct. I just did one myself and got the same result you get. I used to have something somewhere set for a confirmation e-mail to be sent first, then the password, and I obviously must have been using a plugin...and that might have been one of the Theme My Login modules I no longer have enabled.

    edit: Yes, TML. Have a look here: http://wordpress.org/support/topic/user-activation-email-not-sent-user-role-not-switching?replies=4

  5. BeautyPirate
    Member
    Posted 1 year ago #

    I have WP User Control enabled as that works a whole lot better than any other Login Plugin I've tried.

    BUT I'll have a good look at that TML code! ;-)

    Thanks for the hint!

Topic Closed

This topic has been closed to new replies.

About this Topic