WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] eshop checkout error (10 posts)

  1. lewisdonovan
    Member
    Posted 3 years ago #

    Hi, I've just moved to a new server and now, after the user enters their name/address in the checkout page and clicks 'Proceed to confirmation' I get the following error:

    "There appears to have been an error, please contact the site admin"

    Any help would be greatly appreciated

  2. elfin
    Moderator
    Posted 3 years ago #

    you moved the site? As much as I try to support that there are so many things that can cause this after a move.

    If you don't have many products I'd suggest uninstalling and reinstalling eShop.

  3. lewisdonovan
    Member
    Posted 3 years ago #

    Hi, thanks for such a quick response. It's working now. I had to re-enter all the options (shipping, gateways etc) in the admin section, which I had already done, but then I had to deactivate then reactivate the plugin. Not a full uninstall, just a regular deactivate then reactivate the plugin.

    The only other problem I've got left after the move is that the images used on the product pages etc are no longer showing. I've put it in a separate thread HERE.

    Thanks again for the quick response.

  4. GuyWhoCodes
    Member
    Posted 3 years ago #

    I am having a similar problem. I moved the installation to another site. I can add items to my cart, but when I hit Proceed to Checkout it redisplays the cart page saying my cart is emtpy. I have de-activated and re-activated, and updated all my settings again, but it doesn't work. Any suggestions?

  5. lewisdonovan
    Member
    Posted 3 years ago #

    I had many problems after moving my site and it looks like they were almost all session-related. The site wasn't storing cookies properly. I've got mine working normally now with the following fix:

    I added the following to the top of eshop-widget.php, right under the first <?php tag

    session_save_path('WEBROOT PATH/cgi-bin/tmp');
    session_start();

    Obviously you need to replace WEBROOT PATH with your full site root (for example: /home/fhlinux/example.com/user/htdocs/cgi-bin/tmp). You can replace 'cgi-bin/tmp' with whatever directory you want to store the session cookies in. Make sure this directory has CHMOD permissions set to 750.

    The reason this was put in eshop-widget.php is because this file is loaded on every single shop page, this ensures that the session instruction is also loaded on every single shop page.

    Hope this helps.

  6. lewisdonovan
    Member
    Posted 3 years ago #

    If you don't know your webroot path, paste the following into a file called info.php:

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>

    FTP this file to your site and navigate to it in your browser (http://www.example.com/info.php). search for '_SERVER["DOCUMENT_ROOT"]' and next to that you will see the path to the root of your site.

  7. GuyWhoCodes
    Member
    Posted 3 years ago #

    That fixes the problem. It definitely has something to do with the session save path. It would be nice if eShop supports this as a config option in the future, so I don't have to modify plugin files.

  8. lewisdonovan
    Member
    Posted 3 years ago #

    Yeah I agree, wouldn't be too difficult to just have a text area to paste the path into on the back-end.

  9. esmi
    Forum Moderator
    Posted 3 years ago #

    In future can you post either here or in the eShop dedicated forum and not both.

    http://quirm.net/forum/topic.php?id=3290

  10. lewisdonovan
    Member
    Posted 3 years ago #

    Hey esmi, my bad. In fairness they were two separate errors, they just happened to be fixed by the same piece of code.

Topic Closed

This topic has been closed to new replies.

About this Topic