WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error:The theme Directory is either empty or doesn't exist (15 posts)

  1. pcaron7
    Member
    Posted 1 year ago #

    Error:The theme Directory is either empty or doesn't exist. I have seen this in several posts but not quite the same as what I am experiencing. I have a few Woo Themes installed and they all do the same. When I first go to my dashboard or home page it loads very slowly the first time of the day or new window. When it does load up I get that Error message. If I refresh the screen I no longer get the message and the themes are all there. The pages still load slow however. I have tried Explorer but my usual is Chrome.

  2. Tara
    Member
    Posted 1 year ago #

    have you tried:

    -deactivating ALL plugins (yes, all) temporarily to narrow down the problem. If the problem goes away, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive). If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    - To rule out any theme-specific issue, try switching to the unedited default twenty twelve theme for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes via FTP or SFTP or whatever file management application your host provides.

    - also review this troubleshooting 3.5 post: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

  3. pcaron7
    Member
    Posted 1 year ago #

    I have tried;
    1.deleting all plugins
    2. replacing the wp-admin and wp-includes, I also updated the wp-content files individually, and updated the left over files in the root dir.

    I still have the same error message.

  4. Tara
    Member
    Posted 1 year ago #

    Does the wp-content/themes folder exist? If so, is it populated with the twentyeleven and twentytwelve folders?

    If not, try uploading a fresh, unpacked, copy of the Twenty Twelve folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentytwelve

  5. pcaron7
    Member
    Posted 1 year ago #

    I have tried uploading a fresh 2012 theme and it still showing the error message.

  6. Tara
    Member
    Posted 1 year ago #

    check inside the the 2012 theme folder and see if it is populated.

  7. pcaron7
    Member
    Posted 1 year ago #

    Populated as in all files have been uploaded and opened?

  8. Tara
    Member
    Posted 1 year ago #

    Are all files there in the theme folder?

  9. pcaron7
    Member
    Posted 1 year ago #

    Yes all of the files are there.

  10. Tara
    Member
    Posted 1 year ago #

    If there is at least one theme in your theme directory you should check permissions of the files. It should work on setting files and folders in /themes/ to 775 (how you can do this depends on your ftp-software/server. Ask your hosting provider.

  11. pcaron7
    Member
    Posted 1 year ago #

    I have changed the theme folder, such as "twenty twelve," permissions to 775 and still have the error message.

  12. Tara
    Member
    Posted 1 year ago #

    Have you discussed this problem with your hosting provider?

    Also, ask them if there are any limitations/restrictions; or if you need to upgrade the hosting account in order to install and run your verson of the WordPress...

  13. pcaron7
    Member
    Posted 1 year ago #

    Hosting provider assisted me with solving the problem. I had my hosting set up with windows instead of Linnux

  14. Tara
    Member
    Posted 1 year ago #

    Glad you got sorted out :)

  15. pcaron7
    Member
    Posted 1 year ago #

    Me too, thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic