WordPress.org

Ready to get started?Download WordPress

Forums

Errors with widgets.php, wp-login.php & pluggable.php (1 post)

  1. mnboater
    Member
    Posted 6 years ago #

    I'm migrating several blogs to another hosting provider. I have my WP files, v2.5 and exports of my databases. Three imports when fine, minor errors. The last is giving me a headache. I'm using the black-wood-01 theme. I replaced the WP admin and includes with v2.5.1. The error on all pages is:

    Warning: array_keys() [function.array-keys]: /wp-includes/widgets.php on line 1307

    Warning: Invalid argument supplied for foreach() in /wp-includes/widgets.php on line 1307

    When I attempt to login, I get these additional errors:

    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/widgets.php:1307) in /wp-login.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/widgets.php:1307) in /wp-login.php on line 214

    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/widgets.php:1307) in /wp-includes/pluggable.php on line 557

    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/widgets.php:1307) in /wp-includes/pluggable.php on line 694

    Seems to be a common issue. Any help is most appreciated.

    Chris

Topic Closed

This topic has been closed to new replies.

About this Topic