WordPress.org

Ready to get started?Download WordPress

Forums

Stop Spammers
Errors with 4.1 ver of Stop Spammers (9 posts)

  1. JDoe_
    Member
    Posted 1 year ago #

    Following warnings are seen after upgrading this plugin to 4.1
    Deleting and re-installing didn't help either.

    Downgrading to 4.0 helped.

    Warning: fopen(/home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/sfs_debug_output.txt) [function.fopen]: failed to open stream: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1184

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1185

    Warning: fclose(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1186

    Warning: mkdir() [function.mkdir]: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1227

    Warning: fopen(/home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/sfs_debug_output.txt) [function.fopen]: failed to open stream: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1184

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1185

    Warning: fclose(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1186

    Warning: mkdir() [function.mkdir]: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1227

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

  2. David100351
    Member
    Posted 1 year ago #

    I have this installed on one multisite and two standalone wordpress installations (now 3.5), and have not had this issue.

    Where do you see this?

  3. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    It is a permissions issue. You do not have rights to write to the directory.

    The workaround is to go into the options page and set the size of the log file to 0. This will prevent the file from being written.

    I will look for a way to check to see if the file is writeable and include it in a new beta version tonight or tomorrow morning.

    Keith

  4. JDoe_
    Member
    Posted 1 year ago #

    Thanks Keith. But the cache and the history depth which is set to 25 (which I believe is the default) works with 4.0
    Why is there a permissions issue on upgrading to 4.1?

  5. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin writes a history file to the content directory.

    I am making it so there will be an option with a default of OFF in the next release.

    Keith

  6. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Version 4.2 beta now stops these errors and by default turns off the error logging.

    It turns out that many people do not have permissions set to write to the wp-content folder.

    Please go to:

    http://www.blogseye.com/beta-test-plugins/

    and download the latest version if you have having trouble.

    The other alternative might be to give 666 permissions to the wp-content directory.

    Keith

  7. JDoe_
    Member
    Posted 1 year ago #

    Well, wp-content does have user write permissions. The group & world have read+execute.

    But I get it. Thank you.

  8. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I am testing a version that has this feature turned off by default and I will change it so it writes to the plugin's own directory. This will get rid of 99% of the errors.

    It will be done after Christmas, though. Things are a little hectic right now.

    Keith

  9. JDoe_
    Member
    Posted 1 year ago #

    Awesome..thanks for the update. Have a wonderful one.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic