WordPress.org

Ready to get started?Download WordPress

Forums

Errors with 1.5 (4 posts)

  1. Sonny
    Member
    Posted 9 years ago #

    So, this problem started, when I wanted to try Manji 1.02.
    I uploaded unpacked folder into wp-content/themes and choose Manji from Presentation. When I went to the front page of my site, then I got those errors:

    Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/local/php/lib/php/header.php) is not within the allowed path(s): (/www/data/sonny.pri.ee:/tmp) in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 1

    Warning: main(header.php) [function.main]: failed to open stream: Operation not permitted in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 1

    Warning: main() [function.include]: Failed opening 'header.php' for inclusion (include_path='.:/usr/local/php/lib/php') in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 1
    Hello world!
    Posted on Wednesday 12 January 2005

    Welcome to WordPress. This is your first post. Edit or delete it, then start blogging!
    Sonny @ 5:51 pm Edit This
    Filed under: Uncategorized
    1 Comment

    Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/local/php/lib/php/searchform.php) is not within the allowed path(s): (/www/data/sonny.pri.ee:/tmp) in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 60

    Warning: main(searchform.php) [function.main]: failed to open stream: Operation not permitted in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 60

    Warning: main() [function.include]: Failed opening 'searchform.php' for inclusion (include_path='.:/usr/local/php/lib/php') in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 60

    Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/local/php/lib/php/footer.php) is not within the allowed path(s): (/www/data/sonny.pri.ee:/tmp) in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 62

    Warning: main(footer.php) [function.main]: failed to open stream: Operation not permitted in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 62

    Warning: main() [function.include]: Failed opening 'footer.php' for inclusion (include_path='.:/usr/local/php/lib/php') in /www/data/sonny.pri.ee/www/wp-content/themes/Manji-v1-02/index.php on line 62

    I tried many other themes like Mallow, The Simple Life, GreenTrack and Way Too Clean. I always got the same errors.
    Only Kubrick (default WP 1.5 theme) and Classic themes work fine.

    I tried many nightly build like 29.12, 01.01, 06.01 and 13.01.
    But it didn't help me.

    I uploaded files with gFTP in linux, but I also tried flashfXP under windows xp, because I tought, that maby there's something wrong with the gFTP.
    But that didn't help either.

    So I'm pretty confused at the moment.
    (Sorry for my bad english.)

  2. NuclearMoose
    Member
    Posted 9 years ago #

    There have been a few recent changes to the theme system. Perhaps you are using templates which are older versions and are not working properly with 1.5.

    This is one of the caveats of working with beta software...things can, and often do, break. It's a pain, but that's part of what anyone who uses 1.5 must accept.

  3. Cena
    Member
    Posted 9 years ago #

    Although I can't help with your specific problems, I *can* report that Manji 1.02 *does* work with the latest 1.5-beta-1, with no modifications. (I'm using the latest CVS.)

  4. NuclearMoose
    Member
    Posted 9 years ago #

    Cena,
    That's good to know.

    Sonny,
    I did a bit of checking around, and I found this information:

    "Your hosting provider or system admin may have restrictions on which directories can use "includes."
    Run phpinfo.php and do a find on "open_basedir." If the setting is something other than "no value" then you might have to check with your hosting provider."

    Sounds like you should contact your service provider and tell them the problem. I googled the warning message you provided, and I found a lot of sites with that message.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.