WordPress.org

Ready to get started?Download WordPress

Forums

Grand Flagallery - Photo Gallery Plugin
Errors when uploading photos in Multisite (3 posts)

  1. Mike Turner
    Member
    Posted 11 months ago #

    Hi,

    I've just tried installing this plugin and started to upload some images to a new gallery. The images themselves were only around 500k, so I can't see this being a memory error but the issue occurs on creating the thumbnail.

    After the files have uploaded, when it gets to the thumbnail screen the top of the page displays a huge amount of errors (well relative to the number of images being uploaded probably:

    Strict Standards: Non-static method flagAdmin::scandir() should not be called statically in /homepages/16/d476514921/htdocs/amateurphotohub/wp-content/plugins/flash-album-gallery/admin/functions.php on line 159

    Strict Standards: Non-static method flagAdmin::add_Images() should not be called statically in /homepages/16/d476514921/htdocs/amateurphotohub/wp-content/plugins/flash-album-gallery/admin/functions.php on line 204

    Strict Standards: Non-static method flagAdmin::get_MetaData() should not be called statically in /homepages/16/d476514921/htdocs/amateurphotohub/wp-content/plugins/flash-album-gallery/admin/functions.php on line 649

    ..

    Then the last one keeps repeating through.

    However, once the upload process is complete the error disappears and everything seems to be functioning ok.

    Have you seen this issue before? - is there a fix?...if this was just affecting me then I'd just ignore it. But as I said, I'm creating a network of sites which I am offering to my clients and can't expect them to accept these errors being part of the basic package I'm offering.

    If I can get this fixed then I will probably be looking to purchase a full license from you as the plugin is pretty good!

    Many thanks

    Mike

    http://wordpress.org/plugins/flash-album-gallery/

  2. Mike Turner
    Member
    Posted 11 months ago #

    Even if there is a workaround that would be useful. I've heard that you can disable strict errors in PHP but I've tried adding:

    ini_set('display_errors', '0');

    And then

    error_reporting(E_ALL ^ E_STRICT);

    In a php.ini file located in wp-content/plugins/flash-album-gallery/admin/

    I'm hosting with 1&1 and even tried using the console there which allows you to turn off errors for certain directories but still no luck.

    Is there a different folder that I would need to apply this setting to?

    Ideally I'd like to see the errors fixed opposed to working around them, but if there is a way to hide these strict errors just for this plugin then that would be acceptable..just need a pointer!

    Thanks

    Mike

  3. Mike Turner
    Member
    Posted 11 months ago #

    Me again,

    So it appears that PHP 5.4 doesn't allow you to disable strict warnings.

    I've downgraded to PHP 5.2 and have been able to use what I've described above to disable the warnings and it's working fine.

    Would still like to use PHP 5.4 though :(

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.