WordPress.org

Ready to get started?Download WordPress

Forums

Errors when submitting a post (10 posts)

  1. usrbingeek
    Member
    Posted 5 years ago #

    I am using 2.7.1. Could someone please explain how to resolve these errors that I get when submitting a post:

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 109

    Warning: getimagesize(http://www.example.com/wp-content/uploads/2009/05/l-1600-1200-1faea376-5741-419d-92cb-22b6b494b69b.jpeg) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 109

    Warning: imagecreatefromjpeg() [function.imagecreatefromjpeg]: URL file-access is disabled in the server configuration in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 235

    Warning: imagecreatefromjpeg(http://www.example.com/wp-content/uploads/2009/05/l-1600-1200-1faea376-5741-419d-92cb-22b6b494b69b.jpeg) [function.imagecreatefromjpeg]: failed to open stream: no suitable wrapper could be found in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 235

    Warning: imagesy(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 237

    Warning: imagesx(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 239

    Warning: imagecolorat(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 251

    Warning: imagecolorat(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 252

    Warning: imagecolorat(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 253

    Warning: imagecolorat(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 254

    Warning: imagecolorat(): supplied argument is not a valid Image resource in /pathto/www.example.com/wp-content/themes/monotone/functions.php on line 255

    Warning: Cannot modify header information - headers already sent by (output started at /pathto/www.example.com/wp-content/themes/monotone/functions.php:109) in /pathto/www.example.com/wp-includes/pluggable.php on line 850

    (Path and domain intentionally obfuscated for the purpose of this post.)

  2. usrbingeek
    Member
    Posted 5 years ago #

    Problem solved. It was a PHP configuration issue.

  3. theguitarmaster
    Member
    Posted 5 years ago #

    I'm glad you got this issue resolved. I'm now experiencing the same problem. Would you mind sharing your solution?

  4. theguitarmaster
    Member
    Posted 5 years ago #

    [Tue Jun 9 10:58:14 2009] [error] PHP Warning: imagecolorat(): supplied argument is not a valid Image resource in (real-path-removed)/wp-content/themes/monotone/functions.php on line 300

    That's what I'm getting in my error_log.

    Anyone have any ideas?

    Pwetty Pwease?

  5. theguitarmaster
    Member
    Posted 5 years ago #

    The picture does actually upload, but it does not set the CSS for the page correctly (it's always the default black background) and the picture does not show correctly.

    If I edit the code using firebug to remove the width setting of the picture it then does display, but the CSS (which is set at upload time) is not working.

  6. theguitarmaster
    Member
    Posted 5 years ago #

    :-(

  7. theguitarmaster
    Member
    Posted 5 years ago #

    :-(

  8. theguitarmaster
    Member
    Posted 5 years ago #

    :-(

  9. theguitarmaster
    Member
    Posted 5 years ago #

    :-(

  10. odyssey
    Member
    Posted 4 years ago #

    sorry to late response, but my friend told me how to fix this problem.
    by using php.ini, write as follows

    allow_url_fopen = on

    I could solve on my server(media temple).
    FYI//

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags