WordPress.org

Ready to get started?Download WordPress

Forums

Errors after upgrading to 2.7 (11 posts)

  1. nicetec
    Member
    Posted 5 years ago #

    After updating WordPress to 2.7 I cannot work on admin Page. I always get the following error:

    http://n-t.sahty.com/wp-admin/

    Warning: curl_exec() has been disabled for security reasons in /home/nicetec/public_html/wp-includes/http.php on line 1022

    Warning: curl_exec() has been disabled for security reasons in /home/nicetec/public_html/wp-includes/http.php on line 1027

    Warning: Cannot modify header information - headers already sent by (output started at /home/nicetec/public_html/wp-includes/http.php:1022) in /home/nicetec/public_html/wp-includes/pluggable.php on line 850

    Has anybody the same problem and can help me

  2. Sanapaino
    Member
    Posted 5 years ago #

    Whoops, you beat me by 2 minutes: http://wordpress.org/support/topic/224169. Same problem here.

  3. CJK
    Member
    Posted 5 years ago #

    Parece que hay una gran cantidad de problemas con el nuevo WP. Sera esta la version candidata, o es una RC???

  4. Samuel B
    moderator
    Posted 5 years ago #

    that function (curl) is disabled by your host - ask them why
    the "headers already sent" error:
    http://codex.wordpress.org/Answers-Troubleshooting#Headers_already_sent

    este es el lanzamiento oficial despu├ęs de meses de pruebas

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The underlying problem is that your host has disabled curl, but not all of it, so WordPress detects that it is still enabled and attempts to use it. You can choose a different transport with a little minor code hacking.

    First download this plugin and install it:
    http://trac.wordpress.org/attachment/ticket/8086/list_transports.php?format=raw

    After you activate it, you'll see a list of what transports WordPress detected as working at the bottom of the admin screens (in the footer). Once you know these, you can deactivate and delete the plugin.

    Now, curl will probably be on the list, but you know that one doesn't work already. So pick one of the others and add this code to your theme's functions.php file:

    function block_transport() { return false; }
    add_filter('use_http_extension_transport', 'block_transport');
    add_filter('use_curl_transport', 'block_transport');
    add_filter('use_streams_transport', 'block_transport');
    add_filter('use_fopen_transport', 'block_transport');
    add_filter('use_fsockopen_transport', 'block_transport');

    That will block all five possible transports from working. Now just remove the add_filter line on the transport that you want WordPress to actually use.

  6. Sanapaino
    Member
    Posted 5 years ago #

  7. jadiagaurang
    Member
    Posted 5 years ago #

    Hello All,

    I am trying to solve error "Warning: curl_exec() has been disabled for security reasons" but I can not understand how to solve by above description. My domain is http://gaurangjadia.com/wp-login.php

    I can not even login to admin area. Please help me out to solve this error.

  8. SilvioTO
    Member
    Posted 5 years ago #

    I have the same problem here http://www.sb-informatica.it/wp-admin/
    but I'm unable to login for activate the plugin http://trac.wordpress.org/attachment/ticket/8086/list_transports.php?format=raw

    How to resolve? Hope you help me... Thanks.

    Silvio.

  9. SilvioTO
    Member
    Posted 5 years ago #

    Solved, my host reactivate curl function... Thanks.

  10. wiscostorm
    Member
    Posted 5 years ago #

    If you have a theme without a functions.php, where can you paste Otto42's code?

  11. af3
    Member
    Posted 5 years ago #

    You should be able to create a new file, put the code above and save as functions.php in yr theme folder.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags