WordPress.org

Ready to get started?Download WordPress

Forums

  1. Pietro Gregorini
    Member
    Posted 1 year ago #

    Hi there,
    I want to alert you that the plugin give me backs some errors when I try to do backup of database:

    Notice: unserialize() [function.unserialize]: Error at offset 0 of 72 bytes in /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php on line 20

    The debug bar output these 4 warnings:

    WARNING: wp-includes/functions.php:932 - Cannot modify header information - headers already sent by (output started at /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php:20)
    WARNING: wp-includes/functions.php:945 - Cannot modify header information - headers already sent by (output started at /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php:20)
    WARNING: wp-includes/functions.php:3725 - Cannot modify header information - headers already sent by (output started at /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php:20)
    WARNING: wp-admin/admin-header.php:9 - Cannot modify header information - headers already sent by (output started at /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php:20)

    Hope it will be helpful for some bugfix.

    P.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Pietro Gregorini
    Member
    Posted 1 year ago #

    Guys, still no feedback about this issue?
    Please, it's quite annoying.

    Moreover I got other notices from Debug tool, for example when I do some actions with other plugins:

    Notice: unserialize() [function.unserialize]: Error at offset 0 of 96 bytes in /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/secure.php on line 20

    this happens for example with Regenerate Thumbnails plugin, or also in the Dashboard page of the plugin, but this is really less important:

    Browser Compression Supported:
    Notice: Undefined index: HTTP_ACCEPT_ENCODING in /home/pietrogregorini/positive.pietrogregorini.com/core/wp-content/plugins/better-wp-security/inc/admin/content.php on line 959
  3. Handoko
    Member
    Posted 1 year ago #

    Hello.

    The feature of this plugin: Database Backup has been reported several times not working correctly with some webhost environments.

    It requires high RAM which is not available on many shared hosting environments. My suggestion is to use other more resource friendly backup plugin, I use BackUpWordPress.

    Also, FYI you may also need to disable the File Change Detection feature, on my tests it also consumes much server load (CPU and memory).

  4. Pietro Gregorini
    Member
    Posted 1 year ago #

    Hi,
    I was just reporting that issue for knowledge, anyway it wasn't my first requirement for this plugin (I have an automatic backup on my server, so I don't need the plugin for this). Simply, I got a lot of notices in many pages of the back-end, which are referred to that "secure.php" plugin file.

    Thank you anyway for the suggestion!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.