WordPress.org

Ready to get started?Download WordPress

Forums

Widget Logic
[resolved] Error with WordPress 3.8 (6 posts)

  1. jberg1
    Member
    Posted 7 months ago #

    Hello,
    Just updated to WordPress 3.8 and I'm getting this error

    array_push() expects parameter 1 to be array,string given in /wp-content/plugins/widget-logic/widget_logic.php on line 120

    Any idea how resolve this issue?
    Thanks for your help.

    http://wordpress.org/plugins/widget-logic/

  2. alanft
    Member
    Plugin Author

    Posted 7 months ago #

    oh dear that implies that something quite basic has changed in widget controls in 3.8

    i'll take a look this weekend.

  3. alanft
    Member
    Plugin Author

    Posted 7 months ago #

    i've done a very quick install of 3.8 on a dev site, added widget-logic and put in some simple code on one widget and I've not yet seen the error you describe BUT it's not behaving exactly as I would expect from the off, so i'm still investigating the possibility something is wrong.

  4. alanft
    Member
    Plugin Author

    Posted 7 months ago #

    no wait, the unexplained behaviour is now clear to me, and it's to do with the behaviour of a custom widget and not with widget logic. I'll persist with a few stronger tests, but on the face of it, all is well so far.

    Sorry, I don't have any general troubleshooting steps beyond some basic 'turn it off and back on' style suggestions. save out your widget logic code with 'export options' button and clear out your widget logic one at a time until it goes. alternatively deactivate actual widget plugins one by one to find where the problem lies. and so on.

  5. jberg1
    Member
    Posted 7 months ago #

    Oops!
    I see now that it was another plugin that was creating the problem, and throwing the error message I mentioned above. It was an outdated plugin (DP Widget Plus), that once I deactivated it the error went away.

    Sorry for the trouble and waste of time. All is well.
    Thanks for looking into it.

  6. alanft
    Member
    Plugin Author

    Posted 7 months ago #

    no waste of time at all! I needed to get it tested against 3.8 of course. glad all is well

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.