WordPress.org

Ready to get started?Download WordPress

Forums

CMS Tree Page View
Error when using CMS Tree Page View and NextGEN Gallery (8 posts)

  1. Ricardo
    Member
    Posted 3 years ago #

    If you have installed and activated both CMS Tree Page View and NextGEN Gallery, you'll get this warnings when trying to upload an image:

    ERROR: <image-file-name> :
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cms_tpv_plugins_loaded' was given in <wp-local-path>\wp-includes\plugin.php on line 395
    
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cms_tpv_admin_menu' was given in <wp-local-path>\wp-includes\plugin.php on line 395
    
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cms_tpv_admin_init' was given in <wp-local-path>\wp-includes\plugin.php on line 395
    
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cms_tpv_save_settings' was given in <wp-local-path>\wp-includes\plugin.php on line 395

    The images will be uploaded anyway, both plugins work fine, but those warnings surely make it look like they don't, especially when it comes to regular non-tech end users.

    Hope it helps!

    http://wordpress.org/extend/plugins/cms-tree-page-view/

  2. Pär Thernström
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for the bug report. I'll take a look at this.

  3. daledavies
    Member
    Posted 3 years ago #

    Same here without NextGEN Gallery...

    PHP Warning: call_user_func_array() [<a href='function.call-user-func-array'>function.call-user-func-array</a>]: First argument is expected to be a valid callback, 'cms_tpv_plugins_loaded' was given in /xxx/xxx/wp-includes/plugin.php on line 395

  4. Zoinks! Graphics
    Member
    Posted 3 years ago #

    I too am experiencing this error with both CMS Tree Page View and NextGEN Gallery installed in WP 3.0.3. It gets triggered when uploading new images into NextGEN Gallery. The weird thing is the images & thumbnails get generated fine, even though it displays the error every time!

  5. scott4design
    Member
    Posted 3 years ago #

    I am getting this error when people try registering on the site! I am looking for a solution... please... anyone can help?

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in /home/uriel2000/domains/gayburners.com/public_html/wp-includes/plugin.php on line 395

  6. Zoinks! Graphics
    Member
    Posted 3 years ago #

    @Pär Thernström (the developer of CMS Tree Page View) stated 3 months ago: "Thanks for the bug report. I'll take a look at this."

    Just wondering, has this conflict been "de-bugified" in the new version of CMS Tree Page View? (0.7.14)

  7. Pär Thernström
    Member
    Plugin Author

    Posted 3 years ago #

    Not yet I'm afraid. It's still on my todo-list.

  8. Zoinks! Graphics
    Member
    Posted 3 years ago #

    Hi Pär: I see CMS Tree Page View is now up to 0.7.20. Has the conflict with NextGEN Gallery outlined here been worked out in the latest release?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic