WordPress.org

Ready to get started?Download WordPress

Forums

Error when using automatic upgrade feature (5 posts)

  1. nyunyu
    Member
    Posted 5 years ago #

    Got this error.

    Downloading update from http://wordpress.org/wordpress-2.8.4.zip.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2357046 bytes) in /home/xxx/public_html/wp-includes/http.php on line 1331

    Please advice.

  2. metalmd
    Member
    Posted 5 years ago #

    In your wp-settings.php file on line 13 change WP_MEMORY_LIMIT from 32M to 64M. I think even bigger might work, but 64M has worked for me.

  3. kholilal
    Member
    Posted 5 years ago #

    If you receive an error trying to activate your product automatically or using the automatic update feature, you maybe behind a firewall/proxy server which is preventing the process from completing successfully. We have accomodated an alternate method for both so you do not have to change your system settings.

    Magic-jack

  4. adamd1
    Member
    Posted 5 years ago #

    I just did a complete file-by-file update from my old version (2.7.1) to the latest (2.8.4)

    Main index was blank.
    Admin console fails and also shows nothing but a blank page.

    I re-re-uploaded all the old files, but now it's giving me errors regarding the admin dashboard file.

    Upgrade failed completely and my site is only semi-functional.

    This has been a nightmare and I can't seem to get my site back to functional status.

    ADDITIONALLY!

    The new config-sample file did not feature any closing php tags.

    I am of the belief that this upgrade is incomplete.

    I did back everything up but clearly the upgrade process is not working at all.

    DO I now need to start from scratch including a full reinstall of all custom images, widgets, templates, themes, etc.?

    I am now entering hour #3 of this. HELP!

    ad

    --

    UPDATE

    I reverted back to the original and am attempting the automated install. I would like to recommend that this process include separate ftp and database connection credentials. By default it pre-populates with the database credentials, which in nearly every case I have ever seen will be totally different from those used for ftp.

    I still appreciate any kind of feedback. This upgrade definitely appears to have been rushed out without proper QA.

    ad

  5. mrwordpress
    Member
    Posted 5 years ago #

    I was having the same issue and did exactly what "metalmd" posted above and it worked perfectly. It took less than 2 minutes.

    In your wp-settings.php file on line 13 change WP_MEMORY_LIMIT from 32M to 64M. I think even bigger might work, but 64M has worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic