WordPress.org

Ready to get started?Download WordPress

Forums

Error when upgrading to WP2.8 (58 posts)

  1. iblogie
    Member
    Posted 5 years ago #

    Got this error when I upgraded automatically from 2.7.1 to 2.8:

    Warning: gzinflate() [function.gzinflate]: data error in /home/acctname/public_html/wp-includes/http.php on line 1787

    I don't know what the effect is, everything seems to be running fine, but I got this error on all my WP blogs. Also, after the upgrade, WP didn't ask to upgrade the database....

  2. bellamychris
    Member
    Posted 5 years ago #

    I receive similar errors on all of the dashboard pages The blog itself looks fine:

    Warning: gzinflate() [function.gzinflate]: data error in C:\xampp\htdocs\wordpress\wp-includes\http.php on line 1787
    
    Warning: gzuncompress() [function.gzuncompress]: data error in C:\xampp\htdocs\wordpress\wp-includes\http.php on line 1792
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-includes\http.php:1787) in C:\xampp\htdocs\wordpress\wp-includes\functions.php on line 784
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-includes\http.php:1787) in C:\xampp\htdocs\wordpress\wp-includes\functions.php on line 785

    I've tried deactivating and removing all plugins, and switching to the default theme, with no affect.

  3. iblogie
    Member
    Posted 5 years ago #

    I wonder if the theme has something to do with this. I use WooThemes on all my blogs. Can't figure it out yet though...

  4. MichaelH
    Member
    Posted 5 years ago #

    Not exactly the same thing but look at https://core.trac.wordpress.org/ticket/10104 and try this:

    Download this and install it over wp-includes/http.php.
    http://core.trac.wordpress.org/export/11450/trunk/wp-includes/http.php

  5. amanson
    Member
    Posted 5 years ago #

    OK! I am sorry to do this, but can someone please help me with my recent post about headers and editing!

  6. vurtomatic
    Member
    Posted 5 years ago #

    I am getting the same error in my sidebar. I think it's due to the theme I'm using which has Twitter function.

    Here's a screenshot:
    http://kttns.org/kzzgy

    I've tried replacing the original http.php with the mentioned http.php but it's still there.

    Can someone suggest how I can fix this? I am not very familiar with the coding.

  7. Elpie
    Member
    Posted 5 years ago #

    These error messages relate to some new functions for deflate and gzip transfer encodings. They appear to be indicating that the upgrade package has not been able to be correctly unzipped.

    To recover from this, just temporarily deactivate your plugins, do a backup, and do a manual upgrade of 2.8. The manual upgrade will check to see if your database has already been upgraded and, if it hasn't been, it will take you to the database upgrade.

    Don't ignore these errors because its highly likely that you have not got a complete install of 2.8 yet.

    Hope this helps.

  8. iblogie
    Member
    Posted 5 years ago #

    Elpie, thanks very much! Manual upgrading seems to work for me. No more of this error.

  9. seanelavelle
    Member
    Posted 5 years ago #

    Just replacing the http.php in the /wp-includes dir like MichaelH suggested worked perfectly for me.

    Give it a try before you do a full reinstall

  10. paulbm-uk
    Member
    Posted 5 years ago #

    I only receive the warnings from last.fm for WordPress plugin, so I've disabled it for the time being.
    Replacing the http.php didn't make the errors go away for me.

  11. JMcIntyre
    Member
    Posted 5 years ago #

    I am having the same issue as paulbm-uk. That plugin is broken for me in two separate installs of 2.8

  12. Elpie
    Member
    Posted 5 years ago #

    The last.fm plugin is old and is clearly not compatible with WordPress 2.8. I suspect it just might be updated soon though as the developer's own site has that same error showing on it ;)
    I'd recommend uninstalling it and waiting for an updated plugin.

  13. Ricardo Gonzalez
    Member
    Posted 5 years ago #

    I'm on it, but I have no clue about what can be happening...

  14. sablelitreviews
    Member
    Posted 5 years ago #

    I tried to perform an instant upgrade to WP 2.8 and my process page said "done" even though there was no indication that the different steps (downloading upgrade file etc) were being completed. I refreshed and nothing changed so I thought maybe my IE browser wasn't responding. I closed the tab and when I returned to the wp admin url, I received the following error instead of the sign in form:

    Fatal error: Call to undefined method WordPress_Module::_weak_escape() in /home/majorla/public_html/wp-includes/wp-db.php on line 487

    I am unable to sign into my dashboard at all and my home page also shows this error.

    My hosting control panel works as does the site's email. How do I restore the backup or otherwise obtain access to my dashboard?

    I was unable to gain access through FileZilla as well. I get the following error through FileZilla

    530 Login authentication failed

    Thanks,

    Laura

  15. sablelitreviews
    Member
    Posted 5 years ago #

    My hosting company moved a plugin and I was able to install my backfile files with Filezilla by using the control panel webaddress instead of my backoffice web address. aftward I was able to pull up my site and the backoffice login.. When I logged in, WP 2.8 was already running.

    YAY!

    Thanks,
    Laura

  16. MartyThornley
    Member
    Posted 5 years ago #

    I found this same error after doing a manual install.

    Simply reuploaded the 'http.php' file - the same one that was in the 2.8 download and that fixed it.

    Thanks @MichaelH for suggesting it - never would have guessed it was that easy.

  17. kaiserthegreat
    Member
    Posted 5 years ago #

    I'm getting the same error, only my admin section. I did an upgrade automatically and manually, and after that didn't work, I deleted everything and did a fresh install, and I'm still getting the error message. No active plugins, using Default theme.

    I wonder if it's XAMPP related, as I was able to upgrade three hosted WordPress blogs no problem. I noticed the second person who posted in this thread is also using XAMPP. Anyone else?

    Editing out the offending line (#1787) seems to remove the errors and everything runs just fine. Not sure what the consequences are for getting rid of that line though.

  18. MartyThornley
    Member
    Posted 5 years ago #

    Just tried a quick fix and it seemed to work for now:

    Changed line 1787 from

    $decompressed = gzinflate( $compressed );

    to:

    if (false !== $compressed) $decompressed = gzinflate( $compressed );

    The idea being that the error said it was a data error, so that line must not like whatever is coming through in that $compressed variable.

    This might be a better solution than just deleting. That way if some other functions need to use that $compressed variable, it should still work. Right?

  19. jonisolis
    Member
    Posted 5 years ago #

    I just checked my wordpress error_log file and see these:

    [18-Jun-2009 14:09:22] PHP Warning:  gzuncompress() [<a href='function.gzuncompress'>function.gzuncompress</a>]: data error in /home/alove4ho/public_html/wp-includes/http.php on line 1792
    [18-Jun-2009 14:09:22] PHP Warning:  gzinflate() [<a href='function.gzinflate'>function.gzinflate</a>]: data error in /home/alove4ho/public_html/wp-includes/http.php on line 1787
    [18-Jun-2009 14:10:15] PHP Warning:  gzuncompress() [<a href='function.gzuncompress'>function.gzuncompress</a>]: data error in /home/alove4ho/public_html/wp-includes/http.php on line 1792

    I just upgraded to WordPress 2.8 from 2.7.

    What to do to stop these errors? My blog site looks/acts fine for now.

  20. MartyThornley
    Member
    Posted 5 years ago #

    One more strange thing. Even with all these fixes - I get this error everytime I first load the page. But if I refresh, it goes away.

    Maybe all those fixes weren't doing anything, it was just the refresh. What does that mean?

  21. miguelnetto
    Member
    Posted 5 years ago #

    I think we have useful informations about 2.8 update in this article:

    http://dougal.gunters.org/blog/2009/06/18/wordpress-2-8-1-coming-soon

  22. Ricardo Gonzalez
    Member
    Posted 5 years ago #

    It was an internal issue, but now the bug is fixed, see the last.fm plugin page: http://rick.jinlabs.com/code/lastfm

  23. wildbug
    Member
    Posted 5 years ago #

    RickGC, Can you explain what we need to do? I am not a programmer. Do I copy your entire file and paste into mine? Do I need to delete anything in mine? Thanks!

  24. Ricardo Gonzalez
    Member
    Posted 5 years ago #

    wildbug, if you can't wait for the next WP version just overwrite your http.inc file (in wp-includes) with my file (or just copy&paste the entire file, as you said)

    Cheers

  25. Hoosierstu
    Member
    Posted 5 years ago #

    Did upgrading to the newest (beta) version 2.8.1 fix this problem?

  26. hillers54
    Member
    Posted 5 years ago #

    @kaiserthegreat...
    I am using XAMPP as a local server with WordPress 2.8.
    Everything was fine for a couple of days and then I got the line 1787 error messages when going into the dashboard - the site looked fine but the dashboard had all the error messages at the top and the various sections were all over the place. looked as though the CSS positioning had been turned off!

    I tried several of the suggestions, which have been posted but none worked.

    Finally tried your suggestion of deleting line 1787... last resort... and it worked.

    Dashboard looks fine now.

    Anybody solved it yet?

    Is there a bug in 2.8 or is it the combination of XAMPP and WordPress?

  27. wildbug
    Member
    Posted 5 years ago #

    Thanks RickGC but I'm still confused. When I said copy and paste your file, I was referring to your "10163.diff" file that was on your help ticket. But you seem to be implying that I take the http.rar file that has since been uploaded to that linked page and overwrite the http.inc file. Only problem is I can't find an http.inc file. I only see an http.php file! Can you walk me through it from a complete novice's point of view? Sorry to be so clueless! ;-)

  28. Ricardo Gonzalez
    Member
    Posted 5 years ago #

    Sorry, wildbug, I mean http.php
    Just overwrite the original file with the one in my plugin page...

  29. wildbug
    Member
    Posted 5 years ago #

    Thanks RickGC
    So are you saying to overwrite the http.php file with your http.rar file? Because I tried that and it messed everything up. (It doesn't make sense to me why I would replace a file that reads like normal code with one that is all symbols...?)

    Since I am such a newbie at this, it'd be helpful if you could use specific names when referring to files so I know I'm not messing up. For example: "Replace http.php file with http.rar file" Instead of overwrite original with the one on my page...because there are several attachments and being a non-programmer none of it makes sense to me.

    Anyway, it didn't work well for me. If you or anyone else has any other suggestions, please let me know. Thanks!

  30. Steve Bruner
    Member
    Posted 5 years ago #

    I posted the fix on my site. Right-click on the link below and save, change the name to http.php, and overwrite the current one in your wp-includes folder. You should only need this if you're running 2.8. I believe this fix will be included in 2.8.1.

    http://www.slipfire.com/download/http.txt

Topic Closed

This topic has been closed to new replies.

About this Topic