WordPress.org

Ready to get started?Download WordPress

Forums

Mollom
Error when submitting a comment (4 posts)

  1. Bart McLeod
    Member
    Posted 6 months ago #

    I installed mollom initially on 3.6 or so. While upgrading, I didn't notice that it stopped working until now (3.8 version).

    When I submit a comment with the mollom plugin activated, a WSOD (blank screen) is shown when not in debug mode.

    This error is shown on a local test site (that might not have the correct key, since it is running locally):
    Warning: include(): Filename cannot be empty in /[...]/wordpress/wp-content/plugins/mollom/includes/EntityComment.php on line 109 Warning: include(): Failed opening '' for inclusion (include_path='.:/usr/local/zend/share/ZendFramework/library:/usr/local/zend/share/pear') in /[...]/wordpress/wp-content/plugins/mollom/includes/EntityComment.php on line 109

    I'm running php 5.4 on both the local machine and the webserver that has the error.

    http://wordpress.org/plugins/mollom/

  2. Bart McLeod
    Member
    Posted 6 months ago #

    I debugged the code and this is what happens in this particular case:
    There is no single.php template in the theme, while mollom relies on its presence.

    Mollom uses the function get_single_template(), while I do not have a single template. It is a very simple theme, with only an index.php.

    I do have another WordPress blog though, that should have a single.php template and that blog also shows a WSOD when submitting a comment. I should debug that one too, to find out what's going on. For now, I suppose re-using my index.php in single.php should fix the issue I'm seeing.

  3. Bart McLeod
    Member
    Posted 6 months ago #

    With a single.php added to the theme (which simply includes index.php), no error occurs, but instead there is a message: "Post not found." instead of the regular content. Again, debugging is the only option to find out what goes wrong.

    On closer inspection, it is clear that the single.php template is only being used because the post has errors, which might be due to the fact that the site is local and the keys won't work.

    While debugging, it seems the error is that the comment has triggered the spam filter. This would indicate that the keys do work, although the site is local (?).

  4. Bart McLeod
    Member
    Posted 5 months ago #

    It's been a month and none of thee issues reported seem to have been solved. I have been looking into it myself and with a small change to one of the plugin files, I could make it work with a fallback to index.php. Still, I can't figure out why it only works on posts and not on pages (which seems to be the difference right now). Also, the code where I made the change does not get hit on pages. I might continue out of curiosity and to increase my own understanding of WordPress, but for now, I will reduce my rating to 2 stars and report it as broken.

Reply

You must log in to post.

About this Plugin

About this Topic