WordPress.org

Ready to get started?Download WordPress

Forums

SendPress Newsletters
Error when saving sending account setting, sending e-mail is not working (11 posts)

  1. Daniel Hwang
    Member
    Posted 1 year ago #

    While I try to set up [Settings > sending account] and then click save,
    error messages below is displayed.
    Moreover, test e-mail and mail subscription is not working.

    (I can see in the help menu...
    Port 25: blocked
    Port 465: open
    Port 587: open

    But, when I test using php mail function http://darim.com/test.php, it is working)

    =========================================================
    Fatal error: Uncaught exception 'Exception' with message 'Could not find caller class: originating method call is obscured.' in /Absolute path to wordpress/wp-content/plugins/sendpress/inc/functions.php:99 Stack trace: #0 /Absolute path to wordpress/wp-content/plugins/sendpress/classes/views/class-sendpress-view.php(57): get_called_class() #1 /Absolute path to wordpress/wp-content/plugins/sendpress/classes/views/class-sendpress-view-settings-account.php(39): SendPress_View::redirect() #2 /Absolute path to wordpress/wp-content/plugins/sendpress/sendpress.php(674): SendPress_View_Settings_Account->account_setup() #3 /Absolute path to wordpress/wp-includes/plugin.php(406): SendPress->admin_init() #4 /Absolute path to wordpress/wp-admin/admin.php(111): do_action('') #5 {main} thrown in /Absolute path to wordpress/wp-content/plugins/sendpress/inc/functions.php on line 99

    http://wordpress.org/extend/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    Josh may be the best person to answer this question, but I thought that bug or one very similar was fixed in the latest version. Could you use the link below to provide a little bit more information about your setup?

    http://sendpress.com/support/knowledgebase/what-information-should-i-provide-in-a-support-ticket/

    This article will explain a little bit more about problems sending and which ports need to be open.

    http://sendpress.com/support/knowledgebase/troubleshooting-sending-email/

  3. Josh Lyford
    Member
    Plugin Author

    Posted 1 year ago #

    HI Daniel,

    I believe this a bug we have found with running on php less then 5.3. I am working on a fix for this and believe it should be in the next minor release out sometime this weekend.

    Thanks,
    Josh

  4. Daniel Hwang
    Member
    Posted 1 year ago #

    Thank you very much,

    I think my reply is very late.
    Yesterday I was away from internet, sorry~
    There is the information of my setup below.

    Thanks again.

    =============================
    WordPress Version: 3.5.1
    SendPress Version: 0.9.2
    PHP Version: 5.2.9p2
    PHP Memory Limit: 256 MByte
    PHP Memory Used: 35.29 MByte
    MySQL Version: 5.1.45

    Ports:
    Port 25: blocked
    Port 465: open
    Port 587: open
    =============================

  5. Daniel Hwang
    Member
    Posted 1 year ago #

    Hi, now I upgrade to 0.9.3, however, it still doesn't working.
    Now there is no error message, but test e-mail is not delivered.
    How can I do or check more?

    Thanks.
    Daniel

  6. Josh Lyford
    Member
    Plugin Author

    Posted 1 year ago #

    HI Daniel,

    What are you settings on the sending account screen? i see port 25 is blocked that could be your problem now.

    Thanks,
    Josh

  7. Daniel Hwang
    Member
    Posted 1 year ago #

    Hi, This is my sending account screen.
    (http://screencast.com/t/IDrFn9WvOY)
    And still [http://darim.com/test.php] is working good.

    And I attached new debug info below. Thank you.
    =============================
    WordPress Version: 3.5.1
    SendPress Version: 0.9.3
    PHP Version: 5.2.9p2
    PHP Memory Limit: 256 MByte
    PHP Memory Used: 35.32 MByte
    MySQL Version: 5.1.45

    Ports:
    Port 25: blocked
    Port 465: open
    Port 587: open
    ==============================

  8. Daniel Hwang
    Member
    Posted 1 year ago #

    Hi,

    Now I have tested in new test machine with php version 5.3.10.
    It is working good both methods, i.e. through google & web.
    http://screencast.com/t/1vpd4IENNbF

    But, with php 5.2 version, it is not working yet.
    Only simple test my php mail is working, so port 25 is not blocked.
    I think it has still version dependent problem.

    I hope it helps to you.
    Thanks a lot.

  9. Daniel Hwang
    Member
    Posted 1 year ago #

    Hi,

    And if you want to check in our web site closely,
    I can give you temporary credential to you.
    Please let me know your e-mail address.

    Thanks a lot.

  10. Josh Lyford
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Daniel,

    I dont think we need it just yet. I only had 5.2.17 to test with so i am working to setup a few older versions of 5.2 to test.

    Are you able to stay on 5.3.10? or do you need the fix for 5.2 asap?

    Thanks,
    Josh

  11. Daniel Hwang
    Member
    Posted 1 year ago #

    Thanks Josh Lyford,

    Now we need the fix for 5.2 asap.
    In our case, the server of web hosting company supplies 5.2.9p2.
    I have another test machine with version 5.3, but I can not use this one to send lots of email.

    I heartily thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic