WordPress.org

Ready to get started?Download WordPress

Forums

Plugin Organizer
[resolved] Error when saving plugin load order (9 posts)

  1. Robbie_berns
    Member
    Posted 8 months ago #

    Hi - thanks for an amazingly useful plugin.

    I need firstly to resolve an error in a site (within a multisite network). When I alter the sequence on the plugins page and then save, I get an error

    "the order values were not unique so were not saved"

    Any suggestions?

    Many thanks
    ROB

    http://wordpress.org/plugins/plugin-organizer/

  2. Jeff Sterup
    Member
    Plugin Author

    Posted 8 months ago #

    That is not enough info to tell me what the problem is. Do you see any javascript errors on the page? Do you have any php errors in your logs?

  3. Robbie_berns
    Member
    Posted 8 months ago #

    Honestly, there is no Apache error, nor javascript error on the console of Chrome. I am using WP multi-site.

    1. On the plugins admin page, I move some plugins, then click "save plugin load order", ignoring the groups. Is this correct? The resulting pop-up is here

    2. the page definitions definitely do not work.

    3. The "global plugins" settings work perfectly

    Any suggestions?

  4. Jeff Sterup
    Member
    Plugin Author

    Posted 8 months ago #

    Thats supposed to work. Are you on the all plugins page? Have you tried the active plugins page?

  5. Robbie_berns
    Member
    Posted 8 months ago #

    Hi Jeff

    Thanks for all your support!

    I think that I have got my head around how it works: the global settings ALLOW a plugin to be used by pages or filters, where they can be disabled (but not enabled). Is this correct?

    If so, I respectfully suggest that you change the wording on the globals settings page from:
    'Select the plugins you would like to disable site wide. This will allow you to not load the plugin on any page unless it is specifically allowed in the post or page.'
    to something like:
    "If enabled, the following plugins may be disabled on pages or filters. The list is also the default unless altered on a page or filter"

    All of this aside: I am still unable to save the default plugin order.

    Many thanks
    ROB

  6. Jeff Sterup
    Member
    Plugin Author

    Posted 8 months ago #

    No. That's the opposite of how the global plugins page works. By default all plugins are turned on. When you go to global plugins you can turn a plugin off which disables it for the entire site. Then you can go to a page or post and enable it for that particular page or post. Turning the plugin back on with the global plugins page will then enable it for the entire site.

  7. Jeff Sterup
    Member
    Plugin Author

    Posted 7 months ago #

    Version 4.0.1 should fix your issue with the load order.

  8. Robbie_berns
    Member
    Posted 7 months ago #

    Thanks for all your input, Jeff. I have successfully installed 4.0.1

    1. it has solved my problem with fuzzy logic preventing display of custom post type archives - well done
    2. I still cannot save the loading order, unfortunately.
    3. I am unsure how to create a filter for editing a post / custom post. An example url is http://zzz.net/wp-admin/post.php?post=1719&action=edit - can I use wild cards for the post id?

    Happy Saturday
    ROB

  9. Alex Schenker
    Member
    Posted 7 months ago #

    I am also unable to save the loading order. I get a confirmation that the loading order was saved, but when I return to the plugins page they are reset to alphabetical order.

    Take that back, suddenly appears to be working again.

Reply

You must log in to post.

About this Plugin

About this Topic