WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] Error when deleting backups on FTP in 3.0.5 (21 posts)

  1. jamesmartindesign
    Member
    Posted 1 year ago #

    Hello,

    I have been having the following error since about version 3.0.3 with all of my sites - while backing up to FTP:

    WARNING: ftp_delete() [function.ftp-delete]: myFolderName/backwpup_1_2013-03-03_01-02-34.zip: No such file or directory
    [12-Mar-2013 12:58:41] ERROR: Cannot delete "myFolderName/backwpup_1_2013-03-03_01-02-34.zip" on FTP server!
    [12-Mar-2013 12:58:41] WARNING: ftp_delete() [function.ftp-delete]: myFolderName/backwpup_1_2013-03-12_12-53-52.zip: No such file or directory
    [12-Mar-2013 12:58:41] ERROR: Cannot delete "myFolderName/backwpup_1_2013-03-12_12-53-52.zip" on FTP server!
    [12-Mar-2013 12:58:41] WARNING: ftp_delete() [function.ftp-delete]: myFolderName/backwpup_1_2013-02-17_01-01-58.zip: No such file or directory
    [12-Mar-2013 12:58:41] ERROR: Cannot delete "myFolderName/backwpup_1_2013-02-17_01-01-58.zip" on FTP server!

    The backup zips are in-fact there, but are not being pruned as they should. Thank you in advance for your assistance!

    Kind Regards,

    http://wordpress.org/extend/plugins/backwpup/

  2. Caspar
    Member
    Posted 1 year ago #

    Hi jamesmartindesign,
    please make sure /myFolderName/ is readable and writable for BackWPup. (CHMOD 775 or 777)

  3. jamesmartindesign
    Member
    Posted 1 year ago #

    Thanks for the prompt reply Caspar!

    I have checked the file directories that get created by the plugin and they are all set to 775. Any other ideas?

    Kind Regards,

    -- Jim

  4. lrech
    Member
    Posted 1 year ago #

    Up...

    I've tried a rollback to 2.1.17 version and now is working without any problems. No modifications to the structure of the file, neither in permissions, hosts, folders, etc.

    Anything more we could try?

    Regards,

    Ricardo

  5. lrech
    Member
    Posted 1 year ago #

    The solution is rollback to an older version? Seriously? Nothing to do about this?!

  6. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    @Jim Have you tried 777? Also a changed name scheme could interfering? http://wordpress.org/support/topic/delete-old-files-wrong-in-the-last-version?replies=5#post-3964962

  7. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    @Ricardo Was your issue the same as Jims?

  8. lrech
    Member
    Posted 1 year ago #

    Hi, Caspar. Yes, exactly the same issue.

    I've tested exactly the same configuration of a backup job in version 2.1.17 and in version 3.0.5 to a FTP host. In the older version the rotation happens correctly: the new file is transferred and the oldest file is deleted soon afterwards, like expected. However, in the 3.0.5 version, the new file is transferred, but the oldest could not be removed and the log register: "ERROR: Can not delete "path/of/file" on FTP server!". The configuration of two jobs is excactly the same and the names of files have exactly the same structure.

    To be more precise: same hosts, origin (separate installations) and destination (FTP host), same user, same permissions.

    I'm trying to investigate the causes to figure out how to resolve this and help to solve the situation, but, until this moment, I have nothing... =)

    Tks, Caspar. If I find something, I'll put here immediately.

    Regards,

    Ricardo

  9. jamesmartindesign
    Member
    Posted 1 year ago #

    Hi Caspar,

    Thanks for checking in! I am unable to set my directories to 777 as it is a violation of my terms of service with my hosting provider. I am experiencing the same thing Irech is though. Not sure what could be causing it, but I did notice a new release so I will try that and report back.

    Kind Regards,

    -- Jim

  10. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    Kinda running out of ideas here… :( Last things I'asked you guys to test would be:

    1. Update to 3.0.6
    2. Create a new backup job, with a new destination folder (doesn't need to be a complete file backup, though, a single directory like /wp-content/themes/ would do)
    3. Set maximum number of kept files to 1
    4. Run the job manually a couple of times and see if the deletion issue persists
  11. lrech
    Member
    Posted 1 year ago #

    Hi, Caspar, I know... unfortunately, me too.

    I've tried to update, create a new backup job, etc... but not worked.

    Since I'm using IIS over a Windows System, I've tried to use another server, in this case Unix based. However, unfortunately doesn't work.

    I don't know, like I said before, in 2.1.17 version works fine.

  12. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    I guess it goes on our issues list then. Sorry, can't solve it for you right now.

  13. Matt
    Member
    Posted 1 year ago #

    I am having the same issue. To add one another piece, if I go in and try to manually delete them through "BackWPup Manage Backup Archives" it also gives me an error that is not able to delete them, but removes the one I tried to delete from the listing (even though it is correct that it didn't actually delete anything)

  14. Schlappgosch
    Member
    Posted 1 year ago #

    Hi there,

    same thing as to jamesmartindesign happened also to me with version 3.0.6 of BackWPup. I observed this behaviour down to version 3.0.0. on backing up to my ftp server. When the backup directory (ftp/backups in my case) reached the number of allowed backups (20 in my case) those errors and warnings were generated in the report. However, the backup seemed to be correctly written, merely the deletion wouldn't work.

    I employ two groups of backups, a daily one and a weekly one. Two days ago I created two empty(!) subdirectories (ftp/backups/daily and ftp/backups/weekly) and changed the two BackWPup instruction sets accordingly.

    Today I observed that multiple daily backups have been created, yesterday five, and today seven bacups have been written. The timestamps were scattered unregularily across the respective mornings. All had status O.K., since the limit of 20 was not yet reached on that directory and consequently, no deletion attempt did occur. It will probably, when the directory reaches the 20 entries.

    Strange behavior.

    Kind regards

  15. Matt
    Member
    Posted 1 year ago #

    Today I observed that multiple daily backups have been created, yesterday five, and today seven bacups have been written. The timestamps were scattered unregularily across the respective mornings. All had status O.K., since the limit of 20 was not yet reached on that directory and consequently, no deletion attempt did occur. It will probably, when the directory reaches the 20 entries.

    I had noticed the same thing. Seems like something messed up with how this uses cron.

  16. STJO
    Member
    Posted 1 year ago #

    I too have the deletion problem. I get:
    "WARNING: ftp_delete() [function.ftp-delete]: Could not delete xxxxxxx.zip: No such file or directory"
    The file was created by backwpup and I have not moved it.

  17. labarbiche
    Member
    Posted 1 year ago #

    Hi there !
    Thanks Caspar for this great plugin.
    After few investigations, I think the problem is a bug when storing successful backup infos, and retrieving the existing FTP file list:

    These problems appear only when the "Folder to store files in" field is not empty (ie you decide to store your backups in a FTP subfolder)
    When updating the lastbackupdownloadurl (line 335 in class-destination-ftp.php) you use $current_ftp_dir instead of $job_object->backup_folder. This leads to wrong FTP download links in the Backups list.

    In that backup list, the Folder is wrong (it shows on my site (with "Folder to store files in" set to MyFolder): ftp://some.ftp.sever.net:21./ instead of ftp://some.ftp.sever.net:21/MyFolder/ (again, $current_ftp_dir equals '.' and the backup_folder is not taken in account). As a side effect, the date of the backups are always Jan, 1 1970, and backup size always '?'

    This should explain the FTP deletion error.

    I think there's no bugs if you leave the "Folder to store files in" field empty.

    Hope this helps

    Regards !

  18. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    @labarbiche: Thanks.

    I have improved the file deletion and found a bug in filename checking. Will resolved with next update.

  19. lrech
    Member
    Posted 1 year ago #

    @Daniel Huesken: Thanks! Very good news!

  20. STJO
    Member
    Posted 1 year ago #

    Thank you! Great news! And thanks for a great plugin!

  21. lrech
    Member
    Posted 1 year ago #

    Just to inform that this problem is solved in 3.0.7 version. I've updated now and tested. Everything is working fine with file deletion. Thanks to all.

    Best regards,

    Luiz Ricardo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic