WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
Error when authorizing Facebook "Invalid or no certificate authority found" (7 posts)

  1. pixelkicks
    Member
    Posted 1 year ago #

    I'm trying to authorize a new Facebook app I've just created, but I'm getting the following error:

    "Invalid or no certificate authority found, using bundled information".

    My domains all match, and I've tried it a couple of times (removing the app permissions from my profile), but the same error keeps appearing.

    Any ideas?

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    This error means that cURL is misconfigured on your server. Most probably curl ssl(open SSL) is broken or it simply can't find the certificates at the pointed location. Please contact your hosting provider and ask them to fix this.

    http://curl.haxx.se/docs/sslcerts.html

    Unlike Twitter or Google+ that could be automatically switched to non-SSL connections in such cases, Facebook requires to be accessed by SSL at all times.

    Please let me know if you have any questions.

    Ludwig Van Normainen
    NextScripts.com

  3. pixelkicks
    Member
    Posted 1 year ago #

    Hi Ludwig,

    We have a dedicated Windows server using IIS7. I've just checked, and cURL is enabled in PHP.

    Might it be that we need to create a self-signed certificate in IIS for the domain we're using?

    Chris.

  4. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    This is not about server side certificates that you can install. This is about client side certificates that cURL is using to access HTTPS websites. Those are the same certificates that any browser uses. You need to have them on your server and cURL should be configured with the location of such certificates.

  5. pixelkicks
    Member
    Posted 1 year ago #

    Hi,

    I've checked the server config and everything seems fine. However I've seen a few other posts on the internet where users have fixed the issue by editing the following lines in "base_facebook.php":

    public static $CURL_OPTS = array(
    CURLOPT_CONNECTTIMEOUT => 10,
    CURLOPT_RETURNTRANSFER => true,
    CURLOPT_TIMEOUT => 60,
    CURLOPT_USERAGENT => 'facebook-php-3.2',
    CURLOPT_SSL_VERIFYPEER => false, (ADDED THIS LINE)
    );

    I've tested it and this now works, and the plugin successfully posts to the Facebook page.

    Is this something you can fix in a future update so I don't have to edit the files?

    Chris.

  6. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Officially Facebook requires CURLOPT_SSL_VERIFYPEER to be set to true.

  7. pixelkicks
    Member
    Posted 1 year ago #

    Ok, well in the long-term I guess this needs a solution, but the plugin has been working fine for the last few weeks, so currently all is well.

    Will keep any eye out for any future conflicts.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags