WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] Error: wfUtils.php on line 109 (4 posts)

  1. anonymical7
    Member
    Posted 1 year ago #

    Hi guys,

    I was contemplating an upgrade to the paid version, but today I noticed I got this error
    Warning: preg_match() expects parameter 2 to be string, array given in /home/----/----/wp-content/plugins/wordfence/lib/wfUtils.php on line 109

    What can I do to repair this? I first tried upgrading to the new release, but that did not solve it, and so I have deactivated the plugin entirely, but the error message is still there. I deleted the plugin and still had the message...

    I want to remove the message as quickly as possible....

    Anthony

    http://wordpress.org/extend/plugins/wordfence/

  2. anonymical7
    Member
    Posted 1 year ago #

    Line 109 looks like this.

    if(is_string($val) && preg_match('/^\d+\.\d+\.\d+\.\d+/', $val) && strlen($val) < 255){

    Trying to help! Because I need help, the site looks terrible with all these warning messages on there. Why is it showing up even after the plugin has been deactivated and deleted?

  3. anonymical7
    Member
    Posted 1 year ago #

    Well, it seems to be abating, if someone has this problem, a simple deactivation and delete might not work. I had to delete, download the plugin and reinstall and for some magic reason it seems to be disappearing. Heres hoping others dont have any problems similar.

  4. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I think we fixed this in a recent release, so if it shows up again in the latest version, please let me know and we'll get it fixed.

    Thanks,

    Mark.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic