WordPress.org

Ready to get started?Download WordPress

Forums

Knews Multilingual Newsletters
[resolved] Error Warning: strpos() (7 posts)

  1. fermars
    Member
    Posted 1 year ago #

    Hola Carles,

    He instalado Knews hace unos días y estoy probando. Ayer se envió una newsletter sin problemas, llegó bien. Pero hoy (con el nuevo post publicado) ha llegado un mail pero ¡vacío!. Cuando voy a Newsletters creadas automáticamente veo que está en la lista, pero no tiene asignada la plantilla que he creado (y que ayer si funcionó, está listada y con su plantilla bien asignada). Si le doy a previsualizar me muestra un error:

    Warning: strpos() [function.strpos]: Offset not contained in string in /home/gm3conta/public_html/gm3asesores/wp-content/plugins/knews/includes/knews_util.php on line 46

    Que supongo tendrá que ver con eso mismo.
    ¿Qué crees que ha podido suceder?

    Gracias.

    http://wordpress.org/extend/plugins/knews/

  2. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Hello fermars! This is a english support forum :)

    Please, submit me your admin access to contact at knewsplugin dot com and I will take a look...

    Regards,
    Carles.

  3. fermars
    Member
    Posted 1 year ago #

    Thank you Carles, I am sorry about the forum language.
    I am not sure to understand you, are you asking me for the username and password of my WordPress Blog to check out the plug-in installation and configuration?

    In any case, I have programmed another post for tomorrow morning so I will see if the problem occurs again.

    Regards,

    Fernando.

  4. fermars
    Member
    Posted 1 year ago #

    Hello, as I promised yesterday, today the newsletter was sent successfully but I am very intrigued (and worried) about the error. Do you have any suggestion?

    Thank you.

  5. marcsupport
    Member
    Posted 1 year ago #

    We are testing and can't reproduce the issue, someone has this issue?

  6. revenonsanosmoutons
    Member
    Posted 1 year ago #

    Yes, I had this one too today.
    After a few hours testing, I came to the conclusion that, at some point, K-News is looking for the <body> tag.
    Without any attribute.

    If you try <body background="..."> you get the error.

  7. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Hello! Sorry for the delay!!!

    Since Knews 1.4.2 this issue is solved, sorry for the delay...

    However, the right way to create a background for the newsletter are:

    - div inside the body tag, with background color
    - first table with width="100%" and the same background

    Take a look to the Casablanca template.

    Kind regards,
    Carles Reverter.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.