WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error Uploading Media, problems with ID3 Code from WordPress? (6 posts)

  1. tweakben
    Member
    Posted 7 months ago #

    I can upload any file I like to my website..... Except mp4's, and most of the videos I need to host, are mp4's. :)

    Warning: Invalid argument supplied for foreach() in /home/girlsunb/public_html/wp-includes/ID3/module.audio-video.quicktime.php on line 207

    Warning: Invalid argument supplied for foreach() in /home/girlsunb/public_html/wp-includes/ID3/module.audio-video.quicktime.php on line 215
    66

    If you click Libray / Add Media, and use the multi-file uploader, you get that error.

    If you attach the file to a post with the multi-file uploader, you receive no code error like above, it just says "Error".

    If you use the single file uploader, it works great, no problems!

    Any solutions to this one? I'm at a wits end, spent the last 2 days trying to figure it out.

    Thanks!

    Ben

  2. tweakben
    Member
    Posted 7 months ago #

    TEMPORARY fix:

    rm ./wp-includes/ID3/module.audio-video.quicktime.php

    and now everything works fine.

    But it'd be nice to have all of the ID3 modules included in WordPress working!

    So while temporarily patched, certainly not resolved.....

  3. tweakben
    Member
    Posted 6 months ago #

    Bump! :) Any idea what it could be?

  4. tweakben
    Member
    Posted 6 months ago #

    Found a solution from the author of getid3.

    http://www.getid3.org/phpBB3/viewtopic.php?f=3&t=1815

    It's really quite simple, just grab the new id3 files from github and install them over the wordpress ones which are causing the errors.

  5. Blutarsky
    Member
    Posted 4 months ago #

    Same problem here... is there any permanent fix for this?

  6. bevels
    Member
    Posted 3 days ago #

    Thanks very much, this helped me!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.