WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] Error Uploading (23 posts)

  1. WpHuss
    Member
    Posted 1 year ago #

    Hi

    Im trying to upload my Aom file but I keep getting a "Sorry, there was a problem uploading your file. You may need to check your folder permissions or other server settings." error, I ended up changing my file permissions to 777 but still nothing.

    Regards
    WpHuss

    http://wordpress.org/extend/plugins/edge-suite/

  2. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    this means the uploaded file could not be moved into edge_suite/tmp. Does the tmp directory have 777 as well? Was the tmp directory created?

  3. WpHuss
    Member
    Posted 1 year ago #

    Hi,
    just checked and there is no edge_suite/tmp directory, and yes the whole file structure/directory is on 777, Im gonna manually try and create the edge_suite/tmp directory and see if that fixes the issue.

  4. WpHuss
    Member
    Posted 1 year ago #

    Hi
    I manually created the edge_suite/tmp directory but still not luck. :-(

  5. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    if the tmp directory isn't created automatically then the plugin also won't be able to create other necessary folders. What really irritates me is that EdgeSuite didn't detect that the tmp dir wasn't there or that it couldn't create it. Multiple directory and write tests run before copying the files and I don't get how these tests do not fail.

    Are you using the latest version 0.4? Can you please delete the whole edge_suite folder, recreate it and then set it to 777. Any idea if PHP might be running in safe mode?

  6. WpHuss
    Member
    Posted 1 year ago #

    Hi,
    I have WordPress Version 3.4.2 installed which is the latest version available on the site (http://wordpress.org/download/release-archive/), I have no idea if the php is set on safe mode either.

  7. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    ok, I'll check on the safe mode option and add some more tests and commit it to the dev branch. I'll sent you the link, hopefully that will give us a clue on what's going on. In the meantime, what hoster are you on? Then I can check there forums if someone else is having permission issues, that usually helps a lot.

    Thanks

  8. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    It gets stranger, I put my PHP into safe mode and I directly get the message from Edge Suite: "Unable to create directory XXX. Is its parent directory writable by the server?" But I assume you don't get that message?

    Even in normal mode Edge Suite always checks and tries to create wp-content/uploads/edge_suite/project on the manage page and if it can't you get an error message. Do you really not get any other error messages? Anything in the red error box on the manage Edge Suite page?

    It's like all the checks are being ignored and it only crashes when you the server tries to copy the uploaded file. Right now I don't see how that would be possible.

  9. WpHuss
    Member
    Posted 1 year ago #

    Hi, sorry for the late reply.

    I dont get that error, I only get a "Sorry, there was a problem uploading your file. You may need to check your folder permissions or other server settings" error, I use
    Hertzner for Hosting and Ive never had previous issues with them.

  10. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hertzner, really? That makes it even worse as I never had problems with them either ;-)

    Ok, I'll check the code again, add some more checks to the dev branch and let you know. Maybe you can give it a try then

  11. WpHuss
    Member
    Posted 1 year ago #

    Okay, just let me know when.

  12. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I've added a couple more checks.

    Please uninstall the whole plugin on your site and delete all edge suite directories, even the uploads/edge_suite dir, I want to see if the plugin can create anything at all.

    Get the trunk plugin version here:
    http://downloads.wordpress.org/plugin/edge-suite.zip

    Install as usual. Please let me know which directories were created and if you get any error messages at all. All checks should be done even before you try to upload anything.

  13. jmorato
    Member
    Posted 1 year ago #

    Hi Timm, I posted this in another topic....

    Hi,

    I just trying the Edge Suit for wordpress in my own computer with MoWes...I upload the .oam file and doesn't work the upload action. My message error is:

    Tmp test file could not be written to C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite

    One more thing; the /uploads/edge_suite folder or /uploads folder haven,t been created during de edge_suite installation inside /wp-content folder.

    Could you help me?

    I,ve tried to assign the whole control to /wp-content folder but doesn`t work...

    I downloaded de zip you bring above and installed....now the error message is different and similar:

    Edge Suite: Unable to create directory project directory (C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite/project). Is its parent directory writable by the server?
    Tmp test file could not be written to C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite.

    I can wait your answer because I go to bed....

    It doesn,t work yet for me but It,s a great plugin...thanks a lot.

  14. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi jmorato,

    the project directory path is a combination of the absolute path wordpress (or the index.php) sits in (which is C:\MoWes\www\wordpress/ in your case) and the upload directory, usually wp-content/uploads (a path RELATIVE to the index.php!). You seem to have defined an ABSOLUTE upload directory:
    D:\wos1\1\www\wordpress/wp-content/uploads/

    That creates C:\MoWes\www\wordpress/D:\wos1\1\www\wordpress/wp-content/uploads/edge_suite as a project path, which of course can't work.

    I'm not sure that absolute path works for your upload directory at all in wordpress. Did you set the path or did it come with MoWes? Are you able to upload images or anything. Especially on windows I'can see how your external upload dir could be linked into the main wordpress dir. Maybe you can try changing the upload dir to a relative path (Settings > Media >Uploading Files), or just delete the path and wp will use the default relative path. Or do you have the "Full URL path to files" option set as well in this section?

    Cheers, Timm

  15. jmorato
    Member
    Posted 1 year ago #

    Thanks a lot Timm!!!

    It was as easy as you told me! I,ve changed D:\wos1\1\www\wordpress/wp-content/uploads/ by the default wordpress value (wp-content/uploads) in Settings > Media >Uploading Files and it works perfect!
    For now I,ve only chosen the composition in Edge Suite/settings/blog page composition and it works perfect; it appears at the home page....

    One more question...is it possible to know what was edited to make it works? It's nice to see that it works but also is important where and what code file was edited and understand the way it works.

    Last question...In my case I done what I,ve just written; but Is there an exemple, web/video link or other topic
    of the snippet option "if(function_exists('edge_suite_view')){echo edge_suite_view();}"
    and "[edge_animation id="number ID compposition"]" (inserted in a post) you told in your installation guide?

    Thanks a lot.

    PD: I,ve just voted it works ;)

  16. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi jmorato,
    glad to hear it works now. Have you seen the linked tutorial on the plugin page:

    http://edgedocks.com/content/edge-suite-integrate-edge-animate-wordpress

    That's the most detailed tutorial there is. If you want to know what exactly is going on under the hood you have to check the code itself, I tried to document it fairly well. I don't think most users are interested in which paths are altered, which loading function calls are redirected... That's basically what the plugin is for ;-)

  17. Yovel49
    Member
    Posted 1 year ago #

    Thanks for the plug in! I was successful in getting the plug in to work with your hungry test file, but when I uploaded my own oam file I saw it progress to 100%, but i did not get the success screen afterwards, and the file did not appear in the drop down menu as your hungry file did after upload. My oam file is 8.1mb so I changed the max file upload setting to 10, but that did not seem to make a difference.

    Thanks in advance Tim,
    Greg

  18. Yovel49
    Member
    Posted 1 year ago #

    I should add that today I have created a very simple animation as a test, since the one I tried uploading yesterday was very complex, and I wanted to eliminate the possibility of there being a problem with the oam file I was trying to upload.

    It seemed to take quite a long time for the file to upload considering its small size. I had the same results...once the upload progress indicator reached 100% I had hoped to see the success message that the file had been uploaded, but nothing :(

  19. Yovel49
    Member
    Posted 1 year ago #

    problem solved! The new "small" test file that I uploaded was also over 8mb! I guess for some reason when you open a new file in edge it keeps all of your previous assets. Once I deleted the extra assets I was able to successfully upload and install on a WordPress page.

  20. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Yovel49,
    thanks for the feedback. It might be that your server doesn't allow the upload of files of a certain size. Glad you got it to work. I'll keep that in mind for other issues. Will see if I'm able to check the max upload filesize for a server.

  21. Yovel49
    Member
    Posted 1 year ago #

    Hi Tim,
    I've gotten most of the bugs worked out of my basic animation. It is a timeline that covers 8000 plus years of time. I plan to add a lot of scrolling text in the future.

    The current issue I have is in regards to how the layers of the project are rendered when viewed from an android phone. Everything works and appears proper when viewed on a mac, ipad, iphone, and windows 7. With windows 7 the project is displayed properly in chrome and ie. Where I have a problem is with the android phone. When viewed outside of wordpress there is no problem, but when viewed from inside of wordpress the counter wheels are displayed too far forward in the layers of the project.

    My android phone works when viewed direct off my server...
    http://www.cyclesofyah.com/chrono/cycles.html

    BUT when viewed from wordpress...
    http://www.cyclesofyah.com/chrono-test

    the counter wheels are too far forward.

    Any help would be greatly appreciated.

    Thanks,

    Greg

  22. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I tested the page on a S2 with android 4 and all seems to work. Can you make a screenshot? Have you tried rendering it with an iframe?

    [edge_animation id="21" iframe="true"]

  23. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Am closing this issue due to inactivity and as I can't reproduce the error. Please reopen when similar problems occur.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic