WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Error upgrading from WordPress 3.6 to 3.6.1 (26 posts)

  1. Kevin Worthington
    Member
    Posted 10 months ago #

    My issue is very similar to http://wordpress.org/support/topic/error-in-wordpress-361-in-spanish. I will explain:

    When trying to upgrade version 3.6 to 3.6.1, after clicking update, the old 3.6 version page shows up and the 3.6.1 keeps showing as an available update.

    The wp-includes/version.php shows that I am indeed on 3.6.1:
    $wp_version = '3.6.1';

    I have several sites, and only one site has this problem.

    I have also tried manual updates by replacing updated files and running wp-admin/update.php but I get the same result.

    I'm using the regular English download. The wp-includes/version.php inside the download package shows as version 3.6.1.

    I have uploaded all the files, replaced the originals, and it still does not work.

    To me it seems like the actual files are up to date, but something in the database still shows 3.6, and it refuses to update the database to show the correct 3.6.1 version number, but this is just a guess.

    Any help is appreciated. Here's some of my server info:

    OS: Linux
    Server: nginx/1.5.5

    PHP
    v5.4.6-1ubuntu1.4
    GD: 2.0
    Magic Quotes GPC: Off
    Memory Limit: 128.0 MiB
    Max Upload Size: 15.0 MiB

    MYSQL
    v5.5.32-0ubuntu0.12.10.1-log
    Maximum No. Connections: 75
    Maximum Packet Size: 1,024.0 KiB
    Data Disk Usage: 5.0 MiB
    Index Disk Usage: 1.6 MiB

  2. Tara
    Member
    Posted 10 months ago #

    Try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!

  3. Kevin Worthington
    Member
    Posted 10 months ago #

    Thanks for that advice. However, I have already tried that.

  4. Tara
    Member
    Posted 10 months ago #

    Have you also tried:

    -deactivating ALL plugins temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can't get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    - To rule out any theme-specific issue, try switching to the unedited default theme for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using via FTP or SFTP or whatever file management application your host provides. Alternately, you can remove other themes except the default theme. That will force your site to use it.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

  5. Kevin Worthington
    Member
    Posted 10 months ago #

    Thanks for the reply. I actually did try each of those. After I read your post, I tried all of them again; still not successful.

  6. Tara
    Member
    Posted 10 months ago #

    - Try flushing any caching plugins you might be running, as well as server and/or browser caches. Also, try different computer/different browser.

    -If no joy, you may want to contact your hosting provider and discuss the problem with them as well.

  7. Kevin Worthington
    Member
    Posted 10 months ago #

    I tried flushing W3TC; it would have been disabled anyway while the plugins folder was moved/disabled.

    I'm running my own VPS, so there's not much that my hosting company will do for me.

    Thanks for trying. I do appreciate it.

  8. Marcelo Pedra
    Member
    Posted 10 months ago #

    The WP version is retrieved from version.php. That's it. When you browse your new installation, that version is saying 3.6.1?
    You could also export your XML file, backup your widgets (using Steven Gliebe's Widget Importer & Exporter), backup your db, backup your entire website, delete the db, and run the install from the start. After it, you can import your xml and widgets. Obviously, dont touch the wp-content to preserve your uploads. Did you tried this? ;)

  9. Kevin Worthington
    Member
    Posted 10 months ago #

    Yes, I tried this too. I really tried (seemingly) everything, which is why I turned to the forums. I am imagining that the next release (3.6.2?) might resolve this. Thanks for the reply.

  10. Marcelo Pedra
    Member
    Posted 10 months ago #

    Quite strange issue. You better do a complete backup, and start doing daily backups if you update your website regularly. Said this, then you can wait for 3.6.2 to come.
    I'm intrigued, let us know if 3.6.2 solve this.

  11. Anshu Verma
    Member
    Posted 10 months ago #

    Hey,

    Try flushing out (drop/remove) _site_transient_update_core under the option table.

    Thanks

  12. Kevin Worthington
    Member
    Posted 10 months ago #

    @Marcelo Pedra: I have daily backups running, thank you for your reply.

    @Anshu Verma: I just tried that, and the post-update screen stil says "Welcome to WordPress 3.6." Thanks for the idea.

  13. esmi
    Forum Moderator
    Posted 10 months ago #

    Try:
    - switching to the default theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder and the wp-config.php & root .htaccess files - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    - running the upgrade manually via wp-admin/upgrade.php

  14. Kevin Worthington
    Member
    Posted 10 months ago #

    @esmi: I have already been down that road, and it did not solve the issue. Thanks.
    [BTW: I'm using nginx so .htaccess does not apply :) ]

  15. Marcelo Pedra
    Member
    Posted 10 months ago #

    @Kevin: did you tried upgrading WordPress with all the plugins deactivated?

  16. Marcelo Pedra
    Member
    Posted 10 months ago #

    @Kevin: is your WP install using default english or another locale? what about changing the locale of WP and download the update to another language, i.e. spanish?
    The WP packages use to be different between locales. After that, you will be able to reinstall automatically the same language or the original english one ;)

  17. Kevin Worthington
    Member
    Posted 10 months ago #

    Yes, I tried deactivating all plugins, switching to default theme, etc.

    I'm using English and always have. I'm too cautious to install a different locale. Shouldn't English work? Isn't it the default version?

  18. Marcelo Pedra
    Member
    Posted 10 months ago #

    Yes, Kevin, it should work in other locales too. When english fail, you must try your second language ;)

  19. Kevin Worthington
    Member
    Posted 10 months ago #

    I don't speak other languages, and I don't want to mess up my site nor my installation. In the grand scheme of my entire site, this isn't a big issue; it's more of a minor annoyance. :)

  20. Marcelo Pedra
    Member
    Posted 10 months ago #

    OK. I hope it can stay as a "minor annoyance" and you can upgrade to the next WP release and fix this. It's quite a weird situation.

  21. Kevin Worthington
    Member
    Posted 10 months ago #

    Same here. Thanks for the replies.

  22. Caramboo
    Member
    Posted 9 months ago #

    Bit of a shot in the dark this, however, try clearing your Nginx cache if you use it on your site and/or restarting php-fpm or whatever else you use for FasctCGI.

  23. Kevin Worthington
    Member
    Posted 9 months ago #

    Restarting php-fpm now gives me error 500 for all pages. I can load a phpinfo page that I made, but no WordPress pages now.

  24. Kevin Worthington
    Member
    Posted 9 months ago #

    If anyone can help, I'd appreciate it. My whole site is down at the moment.

  25. Kevin Worthington
    Member
    Posted 9 months ago #

    I wound up creating an entirely new version of WordPress in another directory, a fresh database, and then I imported necessary files and database tables to their new counterparts. All seems to be working now. Thanks to everyone who tried to help. I really appreciate it. All the best, Kev.

  26. Kevin Worthington
    Member
    Posted 9 months ago #

    [marking as resolved]

Topic Closed

This topic has been closed to new replies.

About this Topic