WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error: "too many redirects" (5 posts)

  1. mattzellmer
    Member
    Posted 3 years ago #

    I'm having some strange inconsistent problems accessing my WordPress site. The URL I'm referring to is http://thriveid.com.

    Browser access:
    * I can access any page in the site from a desktop browser with no problems.

    * I can access any page in the site from my iPad (Safari Browser) with no problems.

    * If I try to go to the home page using Safari on my iPhone I get an error message: "Safari cannot open the page because too many redirects occurred." But I can access any page other than the home page with no problem. (http://thriveid.com/blog, http://thriveid.com/about, etc.)

    WordPress iOS app:
    * When I try to manage my site using the WordPress iOS app on my iPhone, it all works just fine.

    * When I try to set up the WordPress iOS app to manage my site on my iPad, I get the following message after I enter the URL on the Add Site screen: "The request failed because it redirected too many times."

    Any idea why I'm getting these "too may redirects" errors and/or why they're appearing so inconsistently?

    Thanks!

    Matt

  2. Tara
    Member
    Posted 3 years ago #

    Try resetting your custom permalinks back to the default setting and deleting/renaming your WordPress .htaccess file. If that works, then try reading Using_Permalinks before setting a custom permalink structure again.

    Documentation: http://codex.wordpress.org/Using_Permalinks
    Documentation: http://codex.wordpress.org/Using_Permalinks#Where.27s_my_.htaccess_file.3F

  3. mattzellmer
    Member
    Posted 3 years ago #

    Turns out it was a misconfiguration of the WPtouch plugin. I had it set to redirect from the home page to the home page.

    Thanks for your help.

  4. Tara
    Member
    Posted 3 years ago #

    Glad you got it working.

    Please mark this thread "resolved" using the dropdown in the right panel.

  5. WayLay Design
    Blocked
    Posted 2 years ago #

    Turns out it was a misconfiguration of the WPtouch plugin. I had it set to redirect from the home page to the home page.

    Same here. Fixed my issue with it as well.

Topic Closed

This topic has been closed to new replies.

About this Topic