WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Tags
[resolved] Error that needs solving please. (16 posts)

  1. WhiteEagle1985
    Member
    Posted 1 year ago #

    I'm getting this error:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/uff/public_html/wp-content/plugins/buddypress-group-tags/bp-group-tags.php on line 170 and defined in /home/uff/public_html/wp-includes/wp-db.php on line 992

    Can you please fix this error soon?

    http://wordpress.org/plugins/buddypress-group-tags/

  2. Steve
    Member
    Posted 1 year ago #

    line 170 should be:
    "SELECT meta_value FROM %d WHERE meta_key = 'gtags_group_tags' ", $bp->groups->table_name_groupmeta) );

  3. nguyendam
    Member
    Posted 1 year ago #

    Thank @Steve
    I hope Author this plugin will have update

  4. valuser
    Member
    Posted 11 months ago #

    Have the above error message (exactly as @WhiteEagle1985 reports) on local installs (XAMPP) and on one host server.

    Yet on another host server, the plugin works absolutely perfectly.

    Have tried the solution offered by @Steve (thanks) .

    It does prevent the error message from appearing.

    However the plugin no longer functions.

  5. WhiteEagle1985
    Member
    Posted 11 months ago #

    I'd rather have a functioning plugin. ;)

  6. valuser
    Member
    Posted 11 months ago #

    +1

    Though and I'm only guessing - it may have something to do with the software versions that the host servers are running as it is functioning perfectly on one server yet a mirror (test) site on another host server throws the error as do my local installs.

  7. valuser
    Member
    Posted 11 months ago #

    My previous speculation would seem to be incorrect.

    Because on some local installs this error does NOT occur and the plugin appears to work correctly.

    However it remains the case that on other local installs (as well as on one hosted site) the error still occurs.

    Yet the installs appear to have the same configuration (but it must not actually be the case)

    Quite baffling. Will examine further.

  8. maddogmcewan
    Member
    Posted 11 months ago #

    I have 1000's in php log saying:

    Sep 17, 08:44:35 PHP Warning: Creating default object from empty value in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/buddypress-group-tags/bp-group-tags.php on line 23
    Sep 17, 08:44:35 PHP Warning: Creating default object from empty value in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/buddypress-group-tags/bp-group-tags.php on line 24

  9. lenasterg
    Member
    Posted 10 months ago #

    @maddegmcewan, hi.
    Try replacing the bp_gtags_setup_globals function of buddypress-group-tags/bp-group-tags.php with the following

    function bp_gtags_setup_globals() {
        global $bp;
        if (!isset($bp->gtags) || !is_object($bp->gtags)) {
            $bp->gtags = new stdClass();
        }
        if (!isset($bp->gtags->id) || !is_object($bp->gtags->id)) {
            $bp->gtags->id = new stdClass;
        }
        $bp->gtags->id = 'gtags';
        if (!isset($bp->gtags->slug) || !is_object($bp->gtags->slug)) {
            $bp->gtags->slug = new stdClass;
        }
        $bp->gtags->slug = 'tag';
    }
  10. lenasterg
    Member
    Posted 10 months ago #

    The above is based on http://buddypress.trac.wordpress.org/ticket/4191 about PHP 5.4

  11. valuser
    Member
    Posted 10 months ago #

    Thanks for fix

    tried it.

    Afraid i did not work for me.

    but more mysterious is why on some local instals and not on others ?

  12. lenasterg
    Member
    Posted 10 months ago #

    @valuser hi.
    It has to do with the php version and the error reporting settings in each installation.
    Maybe this can help
    http://stackoverflow.com/questions/9983286/disabling-strict-standards-in-php-5-4

  13. Profusion
    Member
    Posted 8 months ago #

    Hi Forum.
    I have the same problem and I've tried all the suggestions here but not luck. Pity as this is the only plugin that would offer some classification/ sorting of groups if you planning on allowing lots of user generated groups on your buddypress install. Hope the plugin author give it another look.
    Thanks

  14. chancharles
    Member
    Posted 8 months ago #

    I have got the plugin somewhat working with the diff I posted in another topic:

    http://wordpress.org/support/topic/cloud-tag-urls-not-working

    Give it a try. It may work for you too.

  15. Dwenaus
    Member
    Plugin Author

    Posted 7 months ago #

    this is resolved in the latest version of the plugin: 2.1

  16. WhiteEagle1985
    Member
    Posted 7 months ago #

    So far it appears to be working on Canuck Gamers, I'll be adding it to my other sites and watching for errors.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic