WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] error submitting entries (14 posts)

  1. webegmont
    Member
    Posted 1 year ago #

    we're getting the following error showing up when people try and submit an entry.

    "Error: Mail function

    The e-mail could not be sent. Please report this error to the site owner."

    Is this a due to a problem on the developer end? It was fine earlier.

    thank you!

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    The cause of this error is that your host probably disabled the mail() function. Try using the WP Mail SMTP plugin.

  3. neemotech
    Member
    Posted 1 year ago #

    Dear Matthew ,

    Still i am getting the same error after configuring the SMTP also . Please help . Thank You

  4. webegmont
    Member
    Posted 1 year ago #

    It worked when we put an email address in for the entries to go to. Which is a work around until we know what the problem is.

  5. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Having filled in all of the email details isn't a work around. You should always have those completed.

  6. webegmont
    Member
    Posted 1 year ago #

    Ah well that must be the problem them, we never needed to put one in before and it worked fine with all entries being saved on the database. Going forward we will make sure there is an email included if that is now the case.

  7. Tom Auger
    Member
    Posted 1 year ago #

    Something does appear to have changed recently. I have a number of sites running VFB and one running VFB Pro. I have recently done a full update (WP & Plugins) on the non-pro sites (haven't yet updated the pro site). Since that update, we're getting this error. I can try the WP SMTP workaround, but I'm curious - what has changed in the latest update? I wish I could remember whether there was a VFB update or whether it was just updating WP to 3.4.2 that did it...

  8. Tom Auger
    Member
    Posted 1 year ago #

    Update: surprisingly, the emails DO go through, even though the error message is displayed. Just to be clear: using php mail(), the email IS sent through, but the Error message is displayed to the end user. The form submission is also logged in the DB.

  9. Tom Auger
    Member
    Posted 1 year ago #

    Second Update: with WP Mail SMTP activated, set to SMTP and properly configured (test mails work fine), I continue to get the same error with V 2.6.4, though the emails ARE being sent through.

  10. webegmont
    Member
    Posted 1 year ago #

    Thanks for the updates Tom, that's quite interesting!

  11. Tom Auger
    Member
    Posted 1 year ago #

    Third Update: somehow during the latest update (again, not sure whether this is a WP update or a VFB update), the "Notification" settings were lost. What was in fact happening was that the "Notification" option was still turned on, but the reply-to address and other required fields were missing. This is odd, because you cannot turn Notifications on and submit the changes if the required fields are blank. It makes me wonder whether the Options field names were changed during the last update?

    At any rate, this explains the reason the emails were being sent: the email to the admin mailbox were going through, but the error was being generated by the second email (the notification email).

    The solution: check to see whether you have Notifications turned on. If you do, be sure the "reply-to" address is filled in.

  12. whatismyresults
    Member
    Posted 10 months ago #

    Hey Tom, Thanks for the updates, that's quite interesting! I'm trying on this post UP Board But It gives me some error.

  13. saisuresh98
    Member
    Posted 10 months ago #

    Getting the same error while i'm posting on inter results any way to fix it.

  14. ddresults
    Member
    Posted 8 months ago #

    Hello Sir I was using the same on my blog - DD Results
    but getting an error like this
    "Error: Mail function

    The e-mail could not be sent. Please report this error to the site owner.
    any solution please.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.