WordPress.org

Ready to get started?Download WordPress

Forums

BadgeOS
Error sending Badges to Credly (13 posts)

  1. MonaDarling
    Member
    Posted 10 months ago #

    Hi, I can't seem to send my badges to Credly. I click on the mouseover box in the BadgeOS widget and hit "Yes, Send to Credly" and I get "Error: Sorry. Send to Credly Failed."

    I have them set to automatically send to Credly when they are earned, but they aren't.

    http://wordpress.org/plugins/badgeos/

  2. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Mona, this is the second time recently that we've had reports of this issue, so it's one that's already been filed. However, I'll be adding your contributions to the list so we can hopefully get this resolved.

  3. iroller
    Member
    Posted 9 months ago #

    Hi. I am getting the same error message. What is supposed to happen when a user clicks on the "Yes send to Credly"? Is the user asked to login to their Credly account?

  4. Troy Dean
    Member
    Posted 9 months ago #

    I am getting the same error message from the widget or from a shortcode placement.

    Any updates here?

  5. Michael Beckwith
    Member
    Plugin Author

    Posted 9 months ago #

    None that I have directly heard about, but I believe there is another upcoming update soon, so I'm hopeful for everyone that this is addressed in it.

  6. Michael Beckwith
    Member
    Plugin Author

    Posted 6 months ago #

    Anyone still experiencing these issues with the latest versions?

  7. brashell
    Member
    Posted 6 months ago #

    Yes I am Error: Sorry, Send to Credly Failed.

  8. Michael Beckwith
    Member
    Plugin Author

    Posted 6 months ago #

    If you have any knowledge or experience with tracing your way through code and debugging, any information of where the issue is originating from would be awesome.

  9. brashell
    Member
    Posted 6 months ago #

    I already tried, I can't find it anywhere in my logs.

  10. Michael Beckwith
    Member
    Plugin Author

    Posted 6 months ago #

    Due to the amount of people I was seeing have issues with this, I decided to track down what was going on tonight, and believe I found the issue. Filed a GitHub issue for the plugin and we'll see how soon it gets merged in for the next major release.

    You can follow along with the issue at https://github.com/opencredit/badgeos/issues/208

  11. brashell
    Member
    Posted 6 months ago #

    So what exactly is the fix? or has it not been found yet?

  12. Michael Beckwith
    Member
    Plugin Author

    Posted 6 months ago #

    Essentially a missing parameter in the ajax callback, causing the achievement ID to be interpreted as the user ID. We've been discussing the proper fix this morning.

  13. Michael Beckwith
    Member
    Plugin Author

    Posted 4 months ago #

    If anyone is still seeing the issue, could you go to your BadgeOS > Credly Integration settings page inside your WP install, delete the current saved key, and then re-log in to fetch a new copy. Once you've done that, try again with the original issue(s) and let me know if it's showing properly.

    We had someone make a change on Credly's end recently that should have fixed credly integration issues.

Reply

You must log in to post.

About this Plugin

About this Topic