WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] Error Sending Back Up to Email (7 posts)

  1. jplus2
    Member
    Posted 1 year ago #

    Having Problem on Sending Back Up File to Email, it was able to back up the db as well as the files and save it on the disk but it is not able to send it via email. here is the error message

    STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator

    it seems it is complaining about a deprecated function

    Hope this will be addressed soon.

    Thanks for this plug in

    http://wordpress.org/extend/plugins/backwpup/

  2. Chad Warner
    Member
    Posted 1 year ago #

    I'm getting the same error when backing up to a folder and SugarSync. The error occurs throughout the log. Here's an excerpt showing the first occurrence:

    [03-May-2013 07:27:13] Database dump done!
    [03-May-2013 07:27:13] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [03-May-2013 07:27:14] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [03-May-2013 07:32:23] 1. Trying to make a list of folders to back up …
    [03-May-2013 07:32:23] 104 folders to back up.
  3. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    @jplus2 Thanks, issue filed.

    Chad, can you do me a favor and post what the tooltip says when you place your cursor over the date in the log? If you can't get a hold of the actual text with copy/paste, a screenshot via Droplr or Imgurl would do just fine. Thank you!

  4. Chad Warner
    Member
    Posted 1 year ago #

    Here's the title attribute for the first occurrence of the STRICT NOTICE: is_a(): Deprecated.. Let me know if you need anything else.

    [Type: 2048|Line: 486|File: wp-includes/capabilities.php|Mem: 33.00 MB|Mem Max: 33.50 MB|Mem Limit: 256M|PID: 20614|Query's: 119]

  5. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Chad! We'll come back here as soon as there's a fix.

  6. Caspar
    Member
    Plugin Author

    Posted 1 year ago #

    Finally, it looks like this is not a plugin support issue, but an issue with PHP lower than 5.3. See this thread in Trac. is_a() has been un-deprecated in PHP 5.3.

  7. Chad Warner
    Member
    Posted 1 year ago #

    Thanks, Caspar. I followed these instructions to change the site's Bluehost shared hosting from PHP 5.2 to 5.3, and the notices disappeared.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.