WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Error: Sample WP-Cache config file is missing it thinks. (3 posts)

  1. sleeplessinDC
    Member
    Posted 1 year ago #

    I installed the latest version of WP Super Cache and activated it. When I try to go to the settings page, I get the following at the top of a blank page:
    "Error: Sample WP-Cache config file (/.../wp-content/plugins/wp-super-cache/wp-cache-config-sample.php) does not exist.Verify you installation.
    Cannot continue... fix previous problems and retry."

    I checked the FTP files and that file does exist. I uninstalled it and reinstalled it and still get the same error message. The file exists and is 2.9 KB. Why am I getting this errlr?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. lasertits
    Member
    Posted 9 months ago #

    Same exact issue here. I've tried what you've tried in addition to chmod permissions. Having no luck with that plugin. Did you ever get this resolved?

  3. sleeplessinDC
    Member
    Posted 9 months ago #

    A couple of things.
    WP Super Cache attempts to make certain changes to files on your web server. Depending on your server settings and file permissions, you may need to do these tasks manually:

    Create a blank advanced-cache.php file and put it in wp-content/: If you get the message that says, “Warning! /wp-content/advanced-cache.php does not exist or cannot be updated,” you need to make adjustments to the folder permissions on your web server so that the plugin can create the file:

    Using FTP, navigate to your blog’s root directory (the directory that has wp-admin and wp-content).

    Make the wp-content directory writable by changing the directory permissions to 777.

    In your WordPress Dashboard, refresh the WP Super Cache Settings page.

    Make sure that you change the /wp-content folder permissions back to 755 so that the directory is not publicly writable.

    Configure the wp-config.php file: You may get the message, “Error: WP_CACHE is not enabled in your wp-config.php file.”

    To fix this, make sure your wp-config.php file has the correct path for WP Super Cache and that WP_CACHE is set to "true". If it wasn't set up during installation, do the following manually. Above the MySQL Settings, it should have the following lines:

    define('WP_CACHE', true); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', '/home/username/yourdomain/public_html/wp-content/plugins/wp-super-cache/' ); //Added by WP-Cache Manager

    Save the edit and upload the revised wp-config.php file to the server, overwriting the old file. After you refresh your WP Super Cache Settings page again, you should no longer see the error message.

    Using FTP, modify the permissions of your .htaccess file to be temporarily writable (777). Be sure to go back to the web server directory in your FTP program and reset the file permissions on your .htaccess file to 444 to retain security on that file.

    Go to you WP Super Cache Settings page,
    Enable caching: For basic use of WP Super Cache, select the Caching On radio button under the Caching heading on the WP Super Cache Settings page to enable caching on your site and then click the Update Status button.

    You may get a message telling you that your .htaccess file needs to be updated. Check that it has the lines shown in the settings page (should have been added if htaccess was set to 777). If the lines weren't added, add them manually, save the htaccess file, and change mod the permission to 444.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic