WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Error: Posting Comments (10 posts)

  1. diirtyrawr
    Member
    Posted 5 years ago #

    Recently I've been having problems, when someone tries to comment this error just appears:

    Sorry, there was an error. JavaScript and Cookies are required in order to post a comment.

    Please be sure JavaScript and Cookies are enabled in your browser. Then, please hit the back button on your browser, and try posting your comment again. (You may need to reload the page)

    I've tried numerous things (including checking my JavaScript and Cookies) but it doesn't seem to work. Anyone have any suggestions? Thanks.

  2. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Your blog URL would be the best..and also check from the other browser or other system..

    It seems that it is an browser level issue not wordpress blog..

    Thanks,

    Shane G.

  3. Mark / t31os
    Moderator
    Posted 5 years ago #

    If you could provide a link to your site so we can see the problem this might help...

    Since there's ton of users here with different browsers it should be easy to determine if it's browser related or not.

  4. dizzygirl
    Member
    Posted 5 years ago #

    I've got readers emailing me with the same problem. I went in to post a comment to see if I got the same message and sure enough, I did. I'm using Firefox and have AdBlock Plus installed, which I thought was the culprit, but I turned it off and got the same message.

    My blog:
    http://www.dizzy-girl.net

    Any help would be appreciated.

  5. Mark / t31os
    Moderator
    Posted 5 years ago #

    What plugins do you have installed?

  6. dizzygirl
    Member
    Posted 5 years ago #

    Plugins:

    Gravatar
    CommentLuv
    Spam Karma2
    WP-SpamFree
    WP Super Cache

    I'm thinking it may be WP-SpamFree, because I just installed it last week and that's right around the time I started having problems. But when I deactivate it, there's still a problem.

    Thanks again.

  7. Mark / t31os
    Moderator
    Posted 5 years ago #

    Deactivate them all, then test... if things work activate them one at a time testing to see if the problem returns as you go.

  8. dizzygirl
    Member
    Posted 5 years ago #

    Deactivated and it turned out to be CommentLuv. Hopefully others using CommentLuv who have the same problem will find this page.

    I really appreciate the help. Thanks again.

  9. Mark / t31os
    Moderator
    Posted 5 years ago #

    A good wealth of issues posted here turn out to be plugin related, so it seemed a logical step...

    :) Glad you got it working... :)

  10. speerga
    Member
    Posted 4 years ago #

    For anyone else out there having this problem, I just discovered several of my blogs stopped getting comments and one of my regulars told me about it and about this error message.

    I came here, found this thread, and checked my plugins. I don't use "CommentLuv" and never have. In my case, running WP 2.8.4, it was the "WP-Spamfree" plugin. I'm using the latest version, 2.1.0.7.

    Or I WAS using that version -- I've deactivated it for now. And on every blog where I've been using wp-spamfree I've discovered the comment error message appearing. In each case, deactivating wp-spamfree resolved the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic