WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress BP Gallery Plus
Error on uploading a photo (10 posts)

  1. Hope
    Member
    Posted 1 year ago #

    Hello..

    "Parse error: syntax error, unexpected '}' in ...\wp-content\plugins\bp-gallery\includes\templates\album\albumcomments.php on line 76
    Call Stack" appears when uploading a photo and displaying an album..

    http://wordpress.org/extend/plugins/bp-gallery/

  2. caevan
    Member
    Plugin Author

    Posted 1 year ago #

    Can you let me know whether this is happening in the latest version. As I am not getting the error in testing.

  3. Hope
    Member
    Posted 1 year ago #

    Now I get "Your upload failed, please try again. Error was: Specified file failed upload test." whenever i try to upload a photo.

    What could be the reason?

  4. caevan
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Can you tell me the version you are using and the steps you take to get the error.
    I have loaded version 1.2.4 to a test site and have tried uploading images a number of ways but can not get the error to come up. I have encountered this issue before but, was certain I had fixed it.

  5. Hope
    Member
    Posted 1 year ago #

    Hi Caevan,

    I'm using Version 1.2.4 & also trying it on a test site.
    Steps are as follows:
    1- Profile --> Galleries --> Upload Images ---> Chose an album, photo, permission --> upload image ---> "Your upload failed, please try again. Error was: Specified file failed upload test."

    I tried many times with different image types & names, same error.

    2- Also uploading images directly in group triggers the same error.

  6. caevan
    Member
    Plugin Author

    Posted 1 year ago #

    would you be able to post and extract from the error_log file. Or if you could check whether you it is loggin an SQL error, as that was the cause the last time.

  7. caevan
    Member
    Plugin Author

    Posted 1 year ago #

    The error you describe is being reported back at the time of upload of the image to your server.
    Can you tell me which browser you are using?
    I have tested with
    Chrome (current version) (single and multiple file uploads)
    Firefox (current version) (single and multiple file uploads)
    IE9 (current version) (IE9 only supports single file uploads)

    Also are you on a shared host or your own dedicated host?

  8. Hope
    Member
    Posted 1 year ago #

    I tried it on Firefox, Chrome & IE9 (All are latest versions). The same error appeared.

    I'm still trying the plugin on a test self hosted site.

    Would you please give me more details about the cause of this error that occurred with you the last time (as you mentioned previously)?

    Thank you

  9. caevan
    Member
    Plugin Author

    Posted 1 year ago #

    The last time I had upload issues the errors were related to issues with the SQL and extra field media_type not being present in the wp_bp_gallplus_album table.
    I would really like to sort this issue out quickly for you, if possible as this is a test site if you are able to give me ftp access, I can load a debug version of the code and do some testing, otherwise I can send you the file and you will have to send me back the debug file, the second will be slower.
    You can contact me directly through my website http://www.amkd.com.au My timezone is GMT +10 + daylight saving, so there maybe a delay getting back to you.

  10. DolphinGuy
    Member
    Posted 1 year ago #

    Hi Everyone, (@caevan, @Hope)

    Going to splash in here with some feedback for you...

    I had the SAME problem (error), which seems to be related to toggling OFF and ON Image URL Mapping.

    Once you toggle between Image URL Mapping the error is there for 'good'.

    I HAVE THREE TEST SITES SO IS HERE WHAT HAPPENED NEXT. BP Gallery was working fine on the other two sites, 'UNTIL' I again toggled on Image URL Mapping.

    Now site two is broken as well, while site three continues to work perfectly. Unfortunately, once you toggle URL Mapping and get the error, you cannot back out of it. Seems even if I remove BP Gallery and reinstall, the error persists.

    Glad these are only test sites. It's a great plugin, I hope understanding this source of the error will help others - until, of course, you figure out a fix.

    Here is a .jpg of the error before and after toggling URL Mapping.

    https://www.box.com/shared/ayxi6w4y5umo0wygee6b

    Hope all that helps.

    DolphinGuy

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.