WordPress.org

Ready to get started?Download WordPress

Forums

Connections Business Directory
[resolved] Error on upgrade to Connections 7.5.1 (16 posts)

  1. Ruanna
    Member
    Posted 1 year ago #

    Upgrading to 7.4.1 went fine, but with the new version (7.5.1) I get the following error:

    Fatal error: Class 'cnRole' not found in /home/visit/public_html/wp-content/plugins/connections/connections.php on line 461

    And so I've reverted back to 7.4.1.

    I'm running Connections on a subsite of a multisite, using the Market template.

    Thanks!

    http://wordpress.org/extend/plugins/connections/

  2. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Can you explain the process that you used to upgrade? So far this seems to affect .1%, yep, point one percent of upgrades. Not sure why ...

    Just delete the plugin and re-install it and it'll be fine.

  3. Ruanna
    Member
    Posted 1 year ago #

    Hi...

    1) First time I auto-updated, and got the error.
    2) So I used Easy Theme & Plugin Updater to restore back to 7.4.1.
    3) Then (just for fun) I used Easy Theme & Plugin Updater to try to go back to 7.5.1 and got the same error.
    4) And so I repeated step 2 to get back to 7.4.1.

    Today, however, I (as you instructed) deleted 7.4.1 and re-installed 7.5.1 and now I'm good!

    (In case it helps you get to the bottom of the .1%) I'm also running ROT13 and Connections Widgets.

    Thanks for the support! Ruanna

  4. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Did you have the error on the latest update?

  5. Ruanna
    Member
    Posted 1 year ago #

    At first I couldn't download the plugin (connection time-out - go figure!) so I auto-updated and got this:

    "Fatal error: Class 'cnRole' not found in /home/visit/public_html/wp-content/plugins/connections/connections.php on line 489"

    So I restored back to Connections 7.5.1.

    I returned to the repository and this time I was able to get the download - tried to update again using Easy Theme & Plugin Updater. Now I've got a page that says "Template Not Found." (http://www.sierracountynewmexico.info/shopping/a-z/)

    In the past the template (Market) has been stored outside the plugin directory - in wp-content - do I need to move it elsewhere? Let me know, if I don't hear from you soon I'll probably go back to 7.5.1.

    Thanks for the heads up on the update!

  6. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    What the exact shortcode you're using? You have the list_type option set, yes?

  7. Ruanna
    Member
    Posted 1 year ago #

    Nnnnnoooooo.......

    [connections]

    Is my shortcode. Do I need to start reading the instructions? ;)

  8. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    That's really odd! Are the files for the template is in this path:
    ../wp-content/connections_templates/market

  9. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Oh, and Market is showing as activate?

  10. Ruanna
    Member
    Posted 1 year ago #

    That's the path...but when I check to see what template I'm using via the plugin, I'm seeing "Template market can not be found."

    I was thinking I'd try uploading it again using Install (to see what happens)but I'm having trouble finding the original download. I'll keep hunting.

  11. Ruanna
    Member
    Posted 1 year ago #

    Market isn't in my purchase history on your site, either. I'm flummoxed.

  12. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Can you send me your email address using the contact form at the bottom of the page on my site --- to look-up your purchase.

  13. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    I just resent you the details.

  14. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Any chance for a temp admin account, so I can take a look?

  15. Ruanna
    Member
    Posted 1 year ago #

    Okay to send tend temp admin info to the email I just received?

  16. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    @Ruanna

    Yep.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic