WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Salesforce Add-on
[resolved] Error on Submission (6 posts)

  1. Jonathan
    Member
    Posted 1 year ago #

    After upgrading to 2.0.2 we are seeing an error message when the form is submitted. It reads:

    "Warning: extract() [function.extract]: First argument should be an array in /home/folder/public_html/wp-content/plugins/gravity-forms-salesforce/salesforce-api.php on line 536"

    Any ideas on how to fix this? Thanks a lot.

    Jonathan

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

  2. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    That shouldn't happen...

    I'd try re-saving the Gravity Forms Salesforce API Add-on settings.

  3. Jonathan
    Member
    Posted 1 year ago #

    Thanks for the quick response. I went to update the settings and it looked like there had been nothing added previously. I followed the instructions to add my security token and login credentials, but now get an error that reads:

    "API_DISABLED_FOR_ORG: API is not enabled for this Organization or Partner"

    I got the security token from Salesforce, so I'm not sure why I'm getting this error. Any help would be awesome.

    Thanks.

    Jonathan

  4. Jonathan
    Member
    Posted 1 year ago #

    It also looks like there are two plugins installed to manage the integration. One is called Gravity Forms Salesforce API Add-On and the other is called Gravity Forms Salesforce Web to Lead Add-On. Do I need to have both of those installed and activated?

  5. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    @Jonathan - you only need one of them installed.

    If you have the following Salesforce Editions, you can use the included API Add-on:

    * Enterprise Edition
    * Unlimited Edition
    * Developer Edition

    If you use the following Editions, you will use the included Web to Lead Add-on:

    * Personal Edition
    * Group Edition
    * Professional Edition - Note: You can also purchase API access for a Professional Edition.

  6. Jonathan
    Member
    Posted 1 year ago #

    After uninstalling and reinstalling the plugin along with turning off the API Add-on everything seems to be working correctly.

    Thanks a lot for the help.

    Jonathan

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic