WordPress.org

Ready to get started?Download WordPress

Forums

Rotating Tweets (Twitter widget and shortcode)
[resolved] Error on saving data in setting page (15 posts)

  1. otoraby
    Member
    Posted 1 year ago #

    Hi,

    I have newly installed Rotating Tweets, I have built my application on twitter and copied all required keys from twitter on Rotatting Tweets setting page, but when I click on Save Changes button this error will appear at top of page :

    Error message received from Twitter: couldn't connect to host. Please check your API key, secret, token and secret token on the Twitter website.

    How could I solve it?

    http://wordpress.org/extend/plugins/rotatingtweets/

  2. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like your web server is having a problem accessing other sites.

    What happens when you look at a widget or shortcode on the site itself?

    Martin

  3. otoraby
    Member
    Posted 1 year ago #

    This is output of widget:

    Problem retrieving data from Twitter
    Wordpress error code: http_request_failed - couldn't connect to host
    Please check your PHP and server settings.

    Which options should be adjusted on web server?

    Regards
    Omid

  4. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure. Is the server connected to the internet?

    One option is to try installing the Core Control plug-in and disabling cURL.

  5. otoraby
    Member
    Posted 1 year ago #

    Yes, server is connected to Internet.

    I`ve installed Core Control but I can not find any option with cURL name!
    These are available options:

    Updates Module, Filesystem Module,HTTP Access Module, Cron Module, HTTP Access Logger Module

    Regards
    Omid

  6. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    If you switch on the HTTP Access Module, it should let you control the cURL option.

    Hope this helps,

    Martin

  7. otoraby
    Member
    Posted 1 year ago #

    Thank you Martin, I disabled cURL.
    Now I receive this error when I want to store required keys:

    Error message received from Twitter: fopen() function could not connect to https://api.twitter.com/1.1/statuses/user_timeline.json?oauth_consumer_key=B6U ... Please check your API key, secret,

    What does it mean?
    in my server PHP settings allow_url_fopen is On for both Local value and Master value.

  8. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Did you only switch cURL off? It sounds like everything is switched off!?!

    Martin

  9. otoraby
    Member
    Posted 1 year ago #

    Yes, I do, only cURL has been disabled.
    please have a view on this screenshot.

  10. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Many thanks.

    Do you know what might be causing all those 'undefined' settings?

    Are you able to update plug-ins, download templates etc. directly to your WordPress installation?

    Separate from the cURL setting, have you tried switching off the 'Verify SSL connection to Twitter' setting on the Rotating Tweets page?

  11. otoraby
    Member
    Posted 1 year ago #

    Do you know what might be causing all those 'undefined' settings?

    No, I don`t :(

    Are you able to update plug-ins, download templates etc. directly to your WordPress installation?

    Yes, I am.

    Separate from the cURL setting, have you tried switching off the 'Verify SSL connection to Twitter' setting on the Rotating Tweets page?

    Yes, I did but there was no difference.

    Honestly there is one hint about my internet access; twitter website is blocked in my country and I use VPN services to access this website.

    May it affect on plugin performance with or without using VPN?

  12. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    That's probably the problem. WordPress will be using the default settings of your server to access Twitter - and so is getting blocked.

    I don't know how easy it is to get your server to use a VPN.

    Alternatively, you may want to use a JavaScript or iFrame based solution to show your tweets since the data will not go via your server - and should display automatically for people outside your country.

  13. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    PS: There might be an option to fix this via options for /lib/wp_twitteroauth.php, but I'm afraid I don't know enough about VPNs to tell you what they might be...

  14. otoraby
    Member
    Posted 1 year ago #

    Thank you Martin!
    Internet filtering in my country is so complicated and anything is possible to cause such this problem.

    Temporary I will use this plugin (it shows tweets even without VPN or Web Proxies) but I don`t remove your plugin and try to dig more later!

    Sincerely
    Omid

  15. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Interesting. Perhaps it's the SSL security that causes a problem.

    The plug-in you're using uses the old (unsecured) API that's due to switch off on June 11, 2013.

    I wonder if Twitter have thought this through!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic