WordPress.org

Ready to get started?Download WordPress

Forums

WP-United : phpBB WordPress Integration
[resolved] error On "latest forum post " widget (5 posts)

  1. Jim__Raynor
    Member
    Posted 1 year ago #

    Hi .
    whene I add this widget to my widget area I receive this error

    Fatal error: Cannot redeclare div() (previously declared in /home3/gameside/public_html/wp-content/plugins/wp-jalali/inc/jalali-core.php:77) in /home3/gameside/public_html/forum/includes/jalali_true_format.php on line 11

    and wp-jalali is a calender for RTL language people . I think It replace main wp calender (when they translate WP to my language).
    PLZ help .
    And by the way Other widgets works probably .

    http://wordpress.org/extend/plugins/wp-united/

  2. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, that's a strange bug as that widget doesn't touch any other part of WordPress. Can you confirm that the other widgets work ok?

  3. Jim__Raynor
    Member
    Posted 1 year ago #

    yes . they (other widgets ) work probably .
    and I have too ad this.
    this error is showed exactly in the that widget . I mean in tha area of widget . not in whole page of web sit (Sorry . my English is not good ! and I may have a lot of mistakes :-( )

  4. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    That's OK, your English is fine.

    So latest forum topics works OK but not latest forum posts?" I'm quite surprised :-) I'm inclined to blame this as a bug on the other plugin (it is strange behaviour to define a single function in multiple places), but I will take a look first.

    Would it be possible to help debug, as I'll never understand a RTL language plugin...

    if you go to /home3/gameside/public_html/forum/includes/jalali_true_format.php and add debug_print_backtrace(); just before line 11, you should see the call stack when you visit the page. I'd be interested if you could provide me with that output.

    You can then compare the difference between the output provided by the backtrace for the two widgets -- i.e. why one would trigger the problem and not the other.

    If you could provide me with the output from the two instances of the backtrace, I can do the rest. It might be a better idea to use the forums at wp-united.com for this.

  5. Jim__Raynor
    Member
    Posted 1 year ago #

    ok . if my problem with user integration solved . I use forum to continue solving this problem .
    ( that one is more urgent ! )
    And I mark this topic as resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic