WordPress.org

Ready to get started?Download WordPress

Forums

Error on IE8 webpage related to jquery (12 posts)

  1. jackyah333
    Member
    Posted 4 years ago #

    Hi

    I am getting the following error in IE8 (not in Firefox):

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.3; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)
    Timestamp: Thu, 28 Jan 2010 11:26:20 UTC

    Message: Invalid argument.
    Line: 12
    Char: 12949
    Code: 0
    /wp-includes/js/jquery/jquery.js?ver=1.3.2

    What could be wrong? Could it be a plugin that I am using that's causing conflict?

    Thanks

    Jacky

  2. jackyah333
    Member
    Posted 4 years ago #

    Opera complains about an error in wp-includes/js/thickbox/thickbox.css?ver=20090514

    I have not installed a thickbox and have uninstalled and deleted all plugins that might make use of a thickbox, but still I am getting these errors.

    Please help!

  3. KPelto
    Member
    Posted 4 years ago #

    The same problem. I use "Smells Like Facebook" theme.

  4. KPelto
    Member
    Posted 4 years ago #

    I changed the minified jquery.js to developer version from http://jquery.com/

    Then I got better error message on row 4456. I added this debug code before that error line:
    alert( elem.tagName + " -> " + name + "=" + value );

    It resulted that the last alert before the error was:

    DIV - line-height=NaNpx

    I tracked down the element (by element values alerted before) that really were making the error and added some line-height value to it's CSS. Maybe you could get more information from your elements, but I didn't have id or title information on those..

    Now it works and I changed back to original minified version.

  5. af3
    Member
    Posted 4 years ago #

    jackyah -- did u manage to pinpoint where was the error and the fix? I'm using the same time and getting the same error msg.

    Pls share. thanks

  6. af3
    Member
    Posted 4 years ago #

    @kpelto -- sorry, i meant i'm using the same theme smells like fbook. what element what that error referring to?

  7. KPelto
    Member
    Posted 4 years ago #

    I'm not 100%, but I think it was in styles.css and

    input[type=text], textarea {
            color: #777777;
            font-size: 11px;
            padding: 3px;
            line-height: 11px; /* this */
    }
  8. af3
    Member
    Posted 4 years ago #

    Thanks! That actually got me past that error!
    Now the next error is:

    Message: 'attr(...)' is null or not an object
    Line: 96
    Char: 4
    Code: 0
    URI: /themes/smells-like-facebook/script.js?ver=2.9.2

    Hmm still googling trying to fix this... any idea?

  9. KPelto
    Member
    Posted 4 years ago #

    This problem is another error. Not related to jQuery - the topic.
    --
    No idea. Try to update WordPress and/or reinstall theme.

  10. meggsp
    Member
    Posted 4 years ago #

    Hi,

    I have a problem with JQuery, and I can't figure out what's wrong with it.

    Please see here:
    http://hushhushlondon.com/front/

    Stick that into IE8 and it'll come up with a message like below:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; Creative AutoUpdate v1.40.01; AskTB5.5)
    Timestamp: Mon, 29 Mar 2010 01:16:20 UTC

    Message: Object doesn't support this property or method
    Line: 166
    Char: 6
    Code: 0
    URI: http://hushhushlondon.com/front/

    And the code it stages is:
    jQuery("img.flickr.square,img.flickr.thumbnail,img.flickr.small").flightbox();

    Even if I deactivate the flickr plugin (which, the site worked before I installed it), the page still only shows half of it, the scrollbar won't go down far enough....

    Any ideas what this might be? I've been working on it for hours...

    Cheers...

  11. meggsp
    Member
    Posted 4 years ago #

    It appears that this code is the conflict with the scrollbar:
    filter:alpha(opacity=80);

    If I remove that, then the transparency goes but the scrollbar is fixed in IE. But I still get the error message with that Jquery code...

  12. meggsp
    Member
    Posted 4 years ago #

    If I change the theme, it seems to work - the Flickr that is...

Topic Closed

This topic has been closed to new replies.

About this Topic