WordPress.org

Ready to get started?Download WordPress

Forums

Js-appointment
Error on Attempted Activation (2 posts)

  1. lurkmoar
    Member
    Posted 2 years ago #

    The following error is thrown when attempting to activate the plugin on my local machine using BitNami:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected $end in D:\MPM\BitNami WordPress Stack\apps\wordpress\htdocs\wp-content\plugins\js-appointment\js-appointment.php on line 3990

  2. pajaro
    Member
    Posted 2 years ago #

    lurkmoar, the fatal error is do to what we call "lazy" <?....?> tags. js-appointments uses "lazy" tags and correct tages <?php.....?>. Under PHP 5.5 "lazy" tags are not allowed. Better yet PHP.INI default is no "Lazy" tags. You can reverse this by editing your PHP.INI and turning off short_open_tag=on to short_open_tag=Off. this will solve the $end at 3990. Might add the author created a new version (1.5) of js-appointments which I am using after i debugged the $end problem. The 1.5 version is WP 3.2.1 compatible. The 1.5 version has the same problem $end at line no. 4xxx (last line no.). Hope this helps....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic