WordPress.org

Ready to get started?Download WordPress

Forums

Error on add new page (12 posts)

  1. jdlejeune
    Member
    Posted 7 years ago #

    Hello. This happens when I try to post a page. I setup WP and posted all the content, then began adding plugins. The site functions fine, except for the add a new page.

    Thx for any help :D

    WordPress database error: [Unknown column 'none' in 'field list']
    INSERT INTO wp_post2cat (post_id, category_id) VALUES (125, none)

    Warning: Cannot modify header information - headers already sent by (output started at /home/sacredloveandlightenergyhealingcenter/public_html/wp-includes/wp-db.php:102) in /home/sacredloveandlightenergyhealingcenter/public_html/wp-includes/pluggable-functions.php on line 288

    I've searched around and found a few topics with this error, but the pages they recommend for reuploading/checking haven't seemed to help :\

    Here's the setup:
    - WP 2.0.4
    - Calendar 2.0
    - Fold Page List 1.4
    - TextControl 2.0b1
    - WP Database backup 1.7
    - Sidebar widgets 1.0.20060711
    - King Pages 0.53
    - Xinha4WP 1.1

  2. Chris_K
    Member
    Posted 7 years ago #

    Here's the real error, right?


    WordPress database error: [Unknown column 'none' in 'field list']
    INSERT INTO wp_post2cat (post_id, category_id) VALUES (125, none)

    So, I'd start by disabling every plugin that has anything to do with Pages.

  3. jdlejeune
    Member
    Posted 7 years ago #

    I went through and disabled each plugin and attempted a new page after each. I still received the error.

    I then reactivate everything and went back to the public side of things and saw all the new pages in the navigation. So it appears that it's posting the new content, it's just that error (above) appearing after the save/publish button is pushed. :\

    Thanks for your help :)

  4. jdlejeune
    Member
    Posted 7 years ago #

    I just re-read my reply and sounds a bit like I had solved the issue. I haven't... the pages are still updated and posted, but that annoying error keeps appearing. It will definitely throw off the person I'm creating the site for. She isn't very computer-literate and likely will be uncomfortable seeing that each time she updates a page.

    Any help would be greatly appreciated!!

    Thanks,
    JD

  5. jdlejeune
    Member
    Posted 7 years ago #

    I'm now getting this error when I try to upload files through the upload form.

    WordPress database error: [Unknown column 'none' in 'field list']
    INSERT INTO wp_post2cat (post_id, category_id) VALUES (140, none)

    Warning: Cannot modify header information - headers already sent by (output started at /home/sacredloveandlightenergyhealingcenter/public_html/wp-includes/wp-db.php:102) in /home/sacredloveandlightenergyhealingcenter/public_html/wp-includes/pluggable-functions.php on line 288

  6. krishna555
    Member
    Posted 7 years ago #

    unable to open the website desivdeos.net

  7. krishna555
    Member
    Posted 7 years ago #

    unable to open the website shows not linked to server

  8. jdlejeune
    Member
    Posted 7 years ago #

    Hi Krishna555. I don't quite follow what your reply is saying. Could you clarify?

    Thanks,
    JD

  9. spencerp
    Member
    Posted 7 years ago #

    She/he isn't replying to you per se, they just don't know how to start their own new thread..

    @krishna555, please go to the main forum page:
    http://wordpress.org/support

    Scroll to the bottom of the page, click on the best forum that fit's your problem, while in here: http://wordpress.org/support/forum/7, scroll down and fill out the fields. ;)

    spencerp

  10. jdlejeune
    Member
    Posted 7 years ago #

    Can anyone help with this? I'm really stumped :\

  11. NikolaAnne
    Member
    Posted 7 years ago #

    I have exactly the same issues, and had done exactly the same as yourself jdlejeune (check the files, repacced them with fresh copies, disabled all plug-ins, and still no joy.

    I'm stumped, and although I know my way around HTML, pHp is a new language to me.

    My wordpress install is directly into the htdocs dir, and not in a seperate dir, just as yours appears to be. I'm also getting an odd error on my permalinks page that I think may be connected, as the permalinks page says that my .htaccess is not writable, but yet it has 666 permissons...

    I wonder... If we were to move workpress into its own dir , the problem would go away? IE The install I have working 100% on another domain has WordPress the next level down...

    Is it a bug? ;-)

  12. NikolaAnne
    Member
    Posted 7 years ago #

    Hmm, I went and follwed the catagory advice in thehttp://wordpress.org/support/topic/71174?replies=6

    and I now seem to be able to add and edit pages with no hassles...

    So, I would guess it is to do with the "default catagory" no actually registering with the system?

    You want to try that on your install?

Topic Closed

This topic has been closed to new replies.

About this Topic