WordPress.org

Ready to get started?Download WordPress

Forums

WP Socializer
[resolved] Error notifications on site pages with WP Socializer (5 posts)

  1. fwu@square2.com
    Member
    Posted 10 months ago #

    Hello, I have the following errors showing up on my staging site with WordPress 3.6 and WP Socializer 2.4.9.5. Other than for the error notifications, the floating bar appears to be working as expected.

    The following error is displayed on the front end multiple times at the top and at the bottom of all the the site pages.

    Notice: Undefined index: mobmode in /home/sfbagsco/public_html/wp-content/plugins/wp-socializer/includes/wpsr-floatingbar.php on line 28

    Line 28 of wpsr-floatingbar.php:
    $mobmode = ($wpsr_floatbts['mobmode'] == 1) ? ' data-mobmode="0" ' : ' data-mobmode="1" ';

    The following error is displayed on the front end at the bottom of all the the site pages.

    Notice: Undefined variable: socialbt_processed in /home/sfbagsco/public_html/wp-content/plugins/wp-socializer/includes/wpsr-socialbuttons.php on line 361

    Line 361 of wpsr-socialbuttons.php:
    ));
    Code in context:

    case '32px':
    					$socialbt_processed .= wpsr_socialbts_processlist(array(
    						'pUrl' => $url,
    						'pTitle' => $title,
    						'pExcerpt' => $excerpt,
    						'btType' => 'image',
    						'pixel' => '32px',
    						'services' => $services,
    						'sprites' => $sprites,
    						'label' => $label,
    						'target' => $target,
    						'nofollow' => $nofollow,
    						'imgpath' => $imgpath32px,
    						'after' => '',
    						'before' => '',
    						'params' => 'class="wp-socializer-single"',
    					));
    				break;

    Regards,
    fwu

    http://wordpress.org/plugins/wp-socializer/

  2. fwu@square2.com
    Member
    Posted 10 months ago #

    Update: Disabling and re-enabling the floating sharebar (via the Disable the floating sharebar checkbox) appears to have removed the "Undefined index: mobmode" errors but the "Undefined variable" error remains.

    Regards,
    fwu

  3. vaakash
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks for the notification. Those are just warnings due to some undefined variables. This is shown when your site is in debug mode.

    Disable debug mode by adding

    define('WP_DEBUG', false);

    to your wp-config.php file //http://codex.wordpress.org/Debugging_in_WordPress

    I'll fix this issue in the next version.

    Thank you.

  4. vaakash
    Member
    Plugin Author

    Posted 10 months ago #

    Hello,

    This issue is addressed and fixed in the upcoming version 2.4.9.6

    Thank you.

  5. rubab.11
    Member
    Posted 9 months ago #

    Hi vaakash,
    I am using wp socializer. Customize, Start, Buttons, Placement buttons is not appearing in admin as shown in plugin screenshots. WordPress Version is 3.6.1
    Could you please tell me what is problem?
    Please reply me.

Reply

You must log in to post.

About this Plugin

About this Topic