WordPress.org

Ready to get started?Download WordPress

Forums

Team Rosters
[resolved] Error messages when activating plugin (4 posts)

  1. SieniMaagi
    Member
    Posted 11 months ago #

    Hi,

    I have a wordpress site I'm building for my team (football), it's still early in development but every time I activate Team Rosters-plugin (similar thing happens when I try to add a new game with Game Schedule-plugin):

    Notice: Undefined index: use_gallery_links in /path/to/my/site/wp-content/plugins/team-rosters/includes/mstw-team-rosters-admin.php on line 1605 Notice: Undefined index: use_gallery_links in /path/to/my/site/wp-content/plugins/team-rosters/includes/mstw-team-rosters-admin.php on line 1606 Warning: Cannot modify header information - headers already sent by (output started at /path/to/my/site/dev/wp-content/plugins/team-rosters/includes/mstw-team-rosters-admin.php:1605) in /path/to/my/site/wp-includes/option.php on line 571 Warning: Cannot modify header information - headers already sent by (output started at /path/to/my/site/wp-content/plugins/team-rosters/includes/mstw-team-rosters-admin.php:1605) in /path/to/my/site/wp-includes/option.php on line 572

    I have CCTM installed (tried to deactivate it, helped 0) also some other non-content touching plugins (tried to deactivate all of them)

    http://wordpress.org/plugins/team-rosters/

  2. SieniMaagi
    Member
    Posted 10 months ago #

    When I did a fresh installment of a US - version WordPress (was using finnish version earlier) it worked just fine but now as I tried to change back to finnish it went even crazier (no plugins other than your plugins at the moment)

  3. Mark O'Donnell
    Member
    Plugin Author

    Posted 10 months ago #

    Hi SieniMaagi,
    Yes, this is a common problem. PHP is throwing warnings for indices which are not defined, because they haven't been used yet. Then you can sometimes end up with the dreading "headers already sent message", which is not good. Not a big deal, after you run the admin and save the settings once, even without changing them, they go away. In the meantime, just turn off WordPress debug. Edit your wp-config.php file and change

    define('WP_DEBUG', false); to define('WP_DEBUG', true);

    Let me know how that works out.

    -Mark

  4. SieniMaagi
    Member
    Posted 10 months ago #

    Thanks, it's working now

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.