WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] Error messages on Jobs page after upgrade (6 posts)

  1. mathewmackenzie
    Member
    Posted 1 year ago #

    Just upgraded to your latest version - 3.0.6.

    On the Jobs page, above the list of jobs, I am getting the following error message:

    Invalid argument supplied for foreach()...
    (followed by directory listing for plugin)

    The are a few of these errors listed and the jobs won't run at all.

    Any ideas?

    Thanks - Mat

    http://wordpress.org/extend/plugins/backwpup/

  2. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    I need the complet error message

  3. mathewmackenzie
    Member
    Posted 1 year ago #

    OK....

    Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/backwpup/inc/class-page-jobs.php on line 149

    Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/backwpup/inc/class-page-jobs.php on line 163

    Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/backwpup/inc/class-page-jobs.php on line 149

    Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/backwpup/inc/class-page-jobs.php on line 163

  4. michiel71
    Member
    Posted 1 year ago #

    Hi i backup to Google Drive with BackWPup.
    Can you help me with thess error messages in the logs:

    ---

    WARNING: SimpleXMLElement::__construct(): Entity: line 1: parser error : Start tag expected, '<' not found
    WARNING: SimpleXMLElement::__construct(): The request's content type is not accepted on this URL.
    WARNING: SimpleXMLElement::__construct(): ^
    ERROR: S3 Service API: String could not be parsed as XML

    ---

    Full log:
    [INFO] BackWPup version 3.0.6; WordPress version 3.5.1; A project of Inpsyde GmbH developed by Daniel Hüsken
    [INFO] This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions.
    [INFO] BackWPup job: Google_Drive_weekly; DBDUMP+FILE+DBOPTIMIZE
    [INFO] BackWPup cron: 0 3 * * 5; Fri, 5 Apr 2013 @ 03:01
    [INFO] BackWPup job started from wp-cron
    [INFO] PHP ver.: 5.3.21; cgi-fcgi; Linux
    [INFO] Maximum script execution time is 30 seconds
    [INFO] MySQL ver.: 5.5.27
    [INFO] curl ver.: 7.19.7; NSS/3.13.1.0
    [INFO] Temp folder is: /home/michielb/domains/******/public_html/wordpress/wp-content/uploads/backwpup-98372-temp/
    [INFO] Logfile folder is: /home/michielb/domains/******/public_html/wordpress/wp-content/backwpup-98372-logs/
    [INFO] Backup type is: archive
    [INFO] Backup file is: /home/michielb/domains/******/public_html/wordpress/wp-content/uploads/backwpup-98372-temp/backwpup_1_2013-04-05_03-01-31.zip
    [05-Apr-2013 03:01:31] 1. Try to dump database …
    [05-Apr-2013 03:01:31] Set blog into maintenance mode
    [05-Apr-2013 03:01:31] Connected to database michielb_wp on localhost
    [05-Apr-2013 03:01:31] Dump database table "wp_commentmeta"
    [05-Apr-2013 03:01:31] Dump database table "wp_comments"
    [05-Apr-2013 03:01:31] Dump database table "wp_contact_form_7"
    [05-Apr-2013 03:01:31] Dump database table "wp_incarnate_avatars"
    [05-Apr-2013 03:01:31] Dump database table "wp_links"
    [05-Apr-2013 03:01:31] Dump database table "wp_ngg_album"
    [05-Apr-2013 03:01:31] Dump database table "wp_ngg_gallery"
    [05-Apr-2013 03:01:31] Dump database table "wp_ngg_pictures"
    [05-Apr-2013 03:01:31] Dump database table "wp_options"
    [05-Apr-2013 03:01:31] Dump database table "wp_post_relationships"
    [05-Apr-2013 03:01:31] Dump database table "wp_postmeta"
    [05-Apr-2013 03:01:31] Dump database table "wp_posts"
    [05-Apr-2013 03:01:31] Dump database table "wp_postview"
    [05-Apr-2013 03:01:31] Dump database table "wp_term_relationships"
    [05-Apr-2013 03:01:31] Dump database table "wp_term_taxonomy"
    [05-Apr-2013 03:01:31] Dump database table "wp_terms"
    [05-Apr-2013 03:01:31] Dump database table "wp_usermeta"
    [05-Apr-2013 03:01:31] Dump database table "wp_users"
    [05-Apr-2013 03:01:31] Dump database table "wp_xmlgooglemaps"
    [05-Apr-2013 03:01:31] Set blog to normal mode
    [05-Apr-2013 03:01:31] Added database dump "michielb_wp.sql" with 11.07 MB to backup file list
    [05-Apr-2013 03:01:31] Database dump done!
    [05-Apr-2013 03:01:31] 1. Trying to make a list of folders to back up …
    [05-Apr-2013 03:01:31] 590 folders to back up.
    [05-Apr-2013 03:01:31] 1. Trying to create backup archive …
    [05-Apr-2013 03:01:31] Compression method is ZipArchive
    [05-Apr-2013 03:02:05] Backup archive created.
    [05-Apr-2013 03:02:05] Archive size is 97.41 MB.
    [05-Apr-2013 03:02:05] 4939 Files with 133.98 MB in Archive.
    [05-Apr-2013 03:02:06] 1. Trying to send backup file to S3 Service …
    [05-Apr-2013 03:02:07] Connected to S3 Bucket "beslognl" in US
    [05-Apr-2013 03:02:07] Starting upload to S3 Service …
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): Entity: line 1: parser error : Start tag expected, '<' not found
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): The request's content type is not accepted on this URL.
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): ^
    [05-Apr-2013 03:02:07] ERROR: S3 Service API: String could not be parsed as XML
    [05-Apr-2013 03:02:07] 2. Trying to send backup file to S3 Service …
    [05-Apr-2013 03:02:07] Connected to S3 Bucket "beslognl" in US
    [05-Apr-2013 03:02:07] Starting upload to S3 Service …
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): Entity: line 1: parser error : Start tag expected, '<' not found
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): The request's content type is not accepted on this URL.
    [05-Apr-2013 03:02:07] WARNING: SimpleXMLElement::__construct(): ^
    [05-Apr-2013 03:02:07] ERROR: S3 Service API: String could not be parsed as XML
    [05-Apr-2013 03:02:07] 3. Trying to send backup file to S3 Service …
    [05-Apr-2013 03:02:08] Connected to S3 Bucket "beslognl" in US
    [05-Apr-2013 03:02:08] Starting upload to S3 Service …
    [05-Apr-2013 03:02:08] WARNING: SimpleXMLElement::__construct(): Entity: line 1: parser error : Start tag expected, '<' not found
    [05-Apr-2013 03:02:08] WARNING: SimpleXMLElement::__construct(): The request's content type is not accepted on this URL.
    [05-Apr-2013 03:02:08] WARNING: SimpleXMLElement::__construct(): ^
    [05-Apr-2013 03:02:08] ERROR: S3 Service API: String could not be parsed as XML
    [05-Apr-2013 03:02:08] 1. Trying to optimize database …
    [05-Apr-2013 03:02:08] Set blog into maintenance mode
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_bol_bestseller is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_bol_settings is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_commentmeta is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_comments is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_contact_form_7 is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_incarnate_avatars is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_links is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_ngg_album is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_ngg_gallery is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_ngg_pictures is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_options is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_pollsa is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_pollsip is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_pollsq is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_post_relationships is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_postmeta is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_posts is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_postview is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_term_relationships is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_term_taxonomy is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_terms is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_usermeta is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_users is: OK
    [05-Apr-2013 03:02:08] Result of MyISAM table optimize for wp_xmlgooglemaps is: OK
    [05-Apr-2013 03:02:08] Database optimization done!
    [05-Apr-2013 03:02:08] Set blog to normal mode
    [05-Apr-2013 03:02:08] Job done in 37 seconds.

  5. mathewmackenzie
    Member
    Posted 1 year ago #

    Michiel - do you think you could you start a new thread please with your problem, and delete from here - as its not related to my issue.

    Thanks - Mat.

  6. mathewmackenzie
    Member
    Posted 1 year ago #

    Daniel

    Thanks for your help, but after a delete and reinstall of the plugin, the error no longer occurs.

    Whilst you might wish to log this for future reference, as I can no longer replicate the error, I will mark this as resolved.

    Thanks again - Mat

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic