WordPress.org

Ready to get started?Download WordPress

Forums

Error Messages Not Appearing (16 posts)

  1. iselltheta
    Member
    Posted 1 year ago #

    I have two wordpress blogs using the same plugins on both but a different theme on each site.

    On the first site I created and have used for a while any error message such as on the registration form where a user forgets to put in an email address will show that error. Yet on the new site with a different theme, the error message is blank, I only get a box where the message should go.

    Since I am using the same plugins it seems the problem is within the theme. I was hoping someone may have a suggestion of what the problem could be.

    Thank You!

  2. tomontoast
    Member
    Posted 1 year ago #

    Could you post a link?

  3. iselltheta
    Member
    Posted 1 year ago #

    http://rethink-markets.com/ is the site, sorry for forgetting to include that.

  4. iselltheta
    Member
    Posted 1 year ago #

    http://rethink-markets.com/register is a form you can use to generate an error and see specifically what I am talking about. If you skip a field and submit the form you'll see a pink rectangular box at the top of the form with no message inside.

  5. tomontoast
    Member
    Posted 1 year ago #

    That is caused by the contact-form-7 plugin not by wordpress by default. Try the documentation here http://contactform7.com/docs/

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    Which plugins and theme are you referring to?

  7. tomontoast
    Member
    Posted 1 year ago #

    Actually think it might be magic members plugin. Get support at http://www.magicmembers.com/support-center/

  8. iselltheta
    Member
    Posted 1 year ago #

    I use magic members on both sites though. Perhaps it is contact form 7 I don't use that on my other site. But I do get messages both error and non-error when submitting the contact form 7 form.

  9. tomontoast
    Member
    Posted 1 year ago #

    Try disabling contact-form-7 and see

  10. iselltheta
    Member
    Posted 1 year ago #

    I deactivated and no luck, still no errors. My other site that uses magic members works by the way and shows error messages. Any other ideas?

  11. tomontoast
    Member
    Posted 1 year ago #

  12. iselltheta
    Member
    Posted 1 year ago #

    I doubt it is magic members related. Not sure why you are coming back to that but you are. Thanks anyways for trying to help.

  13. tomontoast
    Member
    Posted 1 year ago #

    Because the source html is:

    <div class="mgm_message_error"></div>

    which suggests that mgm (magic members) isn't adding the text for the error message. What makes you think otherwise?

  14. iselltheta
    Member
    Posted 1 year ago #

    I think it is not MM related because I have another site macrostory.com that uses MM and it does populate error messages. I'm using the same version of their plugin. Does that make sense?

  15. tomontoast
    Member
    Posted 1 year ago #

    True but I can't offer any more help to you unless I can have access to your server to do debugging.

  16. iselltheta
    Member
    Posted 1 year ago #

    I appreciate the effort. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.