WordPress.org

Ready to get started?Download WordPress

Forums

Error Messages after server move (15 posts)

  1. sdawson0
    Member
    Posted 1 year ago #

    Hi

    Our host, Dreamhost, recently moved us onto another server and that broke our website. It turned out that it was the WP-super cache plugin that caused the problem. I was advised to delete it and then reinstall it which I did.

    After that the site started to work again, but with the following error messages at the top of each page;

    WordPress database error: [Duplicate column name 'is_featured']
    ALTER TABLE wp_gzpqcn_price ADD is_featured TINYINT( 4 ) NOT NULL DEFAULT '0'

    WordPress database error: [Duplicate column name 'title_desc']
    ALTER TABLE wp_gzpqcn_price ADD title_desc TEXT NOT NULL

    WordPress database error: [Duplicate column name 'cat']
    ALTER TABLE wp_gzpqcn_price ADD cat varchar( 255 ) NOT NULL

    I contacted Dreamhost again and they said;

    "I apologize for the inconvenience. I looked into this for you and see
    that the error you are seeing is your code trying to create a table that already exists. You will need to look into your code and see why it is trying to add data that already exists. I hope this helps. If you have any further questions, please feel free to message me back."

    I don't think I've done anything to alter the code and I have no idea how to fix this.

    The only thing I can think to do is to export all of the posts and reinstall the theme and wordpress again. This isn't ideal as we've had to do a great deal to customise the site.

    If anyone has any suggestions, I'd be very grateful!

    Thanks!

  2. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    What's your domain? I can take a look for you.

  3. sdawson0
    Member
    Posted 1 year ago #

  4. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    It looks like you've been hacked before (and used Sucuri to clean up, good call!)

    You seem to have both WP Super Cache AND W3 Total Cache installed. The best thing to do would be to remove both totally from your server and start over, as running both is giving you a few errors on the back end.

    Once they're both off, see if the error goes away.

  5. sdawson0
    Member
    Posted 1 year ago #

    Hi

    I just tried to login to wordpress to delete the plugins and I'm now being redirected to wp-admin/install.php and I can't login.

  6. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    You'll need to do this manually then via SFTP or SSH.

    Log in and rename /wp-content/plugins to /wp-content/plugins-old

    That said, I went and looked at your database, and your tables look really odd. You should open a support ticket with DreamHost and ask specifically if they can look at your database for guide taiwan adventures and if there's some reason the tables are doubled. It LOOKS like revisioning is on, but I didn't think that was supported.

  7. sdawson0
    Member
    Posted 1 year ago #

    Hi

    Thanks for the reply. I've changed the plugiins file to plugin-old. Still having the same problem.

    I think the tables being double is a result of me using the restore DB button in mysql databases.

    Contacting dreamhost now.

    Cheers

  8. sdawson0
    Member
    Posted 1 year ago #

    Hi

    I've fixed the problem with the database. Still getting the wordpress database error at the top of the site though. All plugins are now disabled.

    Stu

  9. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    I dug around your theme and it looks like that's what created the wp_gzpqcn_price table but since the themes behind a paywall, I can't get at their docs and support to find more information.

    I would try renaming that table to wp_gzpqcn_priceOLD and see if the theme recreates it cleanly for you. You can do that via PHPMyAdmin, off your panel.

  10. sdawson0
    Member
    Posted 1 year ago #

    Hi

    I renamed the table and it recreated a new one, but the problem still exists.

    Thanks

    Stu

  11. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Have you asked the theme dev about this? I don't want to blow it off and not have a fix, but this is very much the theme doing this.

    I change WP_DEBUG to false (define('WP_DEBUG', false);) in your wp-config.php which hides the error. You shouldn't have that set true on a live site, by the way.

  12. sdawson0
    Member
    Posted 1 year ago #

    Hi

    We haven't asked them. Support in the past has been absolutely terrible. They deny any problem that you find exists. We've had to take screenshots of problems in the past to convince them that something was wrong with the theme.

    Would it help if I sent you the theme files?

    Thanks so much for all the help!

    Stu

  13. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    It's a bit outside my skill level. I mean, I can (and did) skim the code on your account, but reverse engineering a complicated theme like that would take a long time, and even then I can't promise a solution :/ I'm better with plugins than themes.

    Is the site working okay now that I hid the error? It may not be a functional error (that is, one that breaks functions).

  14. sdawson0
    Member
    Posted 1 year ago #

    Hi

    Yes, the site is working fine now that the error has been hidden.

    Cheers

    Stu

  15. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    I think then that it's not an 'error' as much as an 'alert.'

    Which is stupid, IMO, but this is why I don't do themes ;)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags