WordPress.org

Ready to get started?Download WordPress

Forums

Taxonomy Images II
[resolved] Error message when using (9 posts)

  1. bren5ki
    Member
    Posted 2 years ago #

    Warning: Invalid argument supplied for foreach() in ***/wp-content/plugins/category-images-ii/category-images-ii.php on line 233

    Anyone have a solution?

  2. Simon Wheatley
    Code for the People
    Plugin Author

    Posted 2 years ago #

    Please try the latest version and let me know if it helps.

  3. livepulse
    Member
    Posted 2 years ago #

    It did not help. The previous version was working correctly then when I upgraded to WordPress 3.2 and 1.21 of this extension everything stopped working.

    We have this plugin called from our sidebar template, The template codes provided do not display the image. Rather, they display a broken image with a link to the category.

    We were previously using:

    <?php echo $CategoryImagesII->display_images( array(6),"1"); ?>

    which worked great. Any advice?

  4. livepulse
    Member
    Posted 2 years ago #

    My error is:

    Warning: Missing argument 3 for CategoryImagesII::display_images(), called in /home/nadoorg/public_html/wp-content/themes/nado/sidebar-advocacy.php on line 8 and defined in /home/nadoorg/public_html/wp-content/plugins/category-images-ii/category-images-ii.php on line 197

  5. Simon Wheatley
    Code for the People
    Plugin Author

    Posted 2 years ago #

    Try v1.31 and see if they work better for you.

  6. Paul
    Member
    Posted 2 years ago #

    Tonight I tried v1.3.1 and it's not working (WP 3.2.1). This error appears at the top of the page in the admin:

    Warning: Invalid argument supplied for foreach() in [path]/category-images-ii/class-Category-Images-II.php on line 602

  7. Simon Wheatley
    Code for the People
    Plugin Author

    Posted 2 years ago #

    Hi Paul – Thanks for letting me know. Can you check if there's a directory called "category-images-ii" in your wp-content/uploads directory, please?

    Would you try the dev version, here http://dl.dropbox.com/u/72676/110815%20-%20ciii/ciii.zip, and let me know if there's an issue, please?

    Thank you.

  8. Paul
    Member
    Posted 2 years ago #

    Hi Simon,

    Thanks for the quick reply. The category-images-ii directory did exist. It had permissions of 755. I installed the dev version and no longer see the error. It looks like it's fixed. :)

    Thanks,

    paul

  9. Ali Jahangiri
    Member
    Posted 1 year ago #

    Hi,

    I have same problem after updating to the last version of wordpress. Here is my error:

    Warning: Invalid argument supplied for foreach() in /home/content/m/y/d/DOMAIN/html/wp-content/themes/jewelry2/view/category-images-ii/category-images.php on line 2
    Fatal error: Call to undefined function n_round() in /home/content/m/y/d/DOMAIN/html/wp-content/themes/jewelry2/functions.php on line 413
    
    The category-images-ii folder is exsit and it has right permision.

    Thanks,
    Al

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic