WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-to-lead for Salesforce CRM
[resolved] Error Message When Submitting from Sidebar (8 posts)

  1. mstaretorp
    Member
    Posted 5 months ago #

    SMTP -> Error: Failed to connect to server

    I get this error message when a form that I have placed in the sidebar is submitted (tested multiple browsers and it occurs in Safari and Chrome, at the very least). The submission is successful and I get the lead in SF, so Im not sure what is causing this message. Forms not in the sidebar don't cause this message.

    Sidebar: http://www.macresco.com/mthink/

    Functioning form: http://www.macresco.com/contact-us/

    Thanks!

    https://wordpress.org/plugins/salesforce-wordpress-to-lead/

  2. Nick Ciske
    Member
    Plugin Author

    Posted 5 months ago #

    Sorry, this is well below the plugin level -- this is WordPress trying to send email via SMTP and the connection timing out. Why? I haven't the foggiest. Why only sidebar forms? No clue -- the code that runs is the same in either case.

    The stack:

    plugin
    wp_mail()
    php_mailer
    mail server provided by your webhost - this is where the timeout occurs, it just bubbles up the stack and is display by WP since you have debugging on

    This may help:
    http://stackoverflow.com/questions/21693388/phpmailers-infamous-smtp-error-failed-to-connect-to-server-connection-timed-o

    But there's nothing I can do to fix this, sorry!

  3. mstaretorp
    Member
    Posted 5 months ago #

    Could this be why the users also don't get a copy of their submissions?

  4. Nick Ciske
    Member
    Plugin Author

    Posted 5 months ago #

    Yes, if one connection times out, I suspect the other would as well.

  5. mstaretorp
    Member
    Posted 5 months ago #

    Sigh, oh well. Thanks for the help! Love the plugin otherwise!

  6. Nick Ciske
    Member
    Plugin Author

    Posted 5 months ago #

    I'd ask your host. There's something funky going on with outgoing mail.

    Or try a SMTP plugin or Mandrill to route around the issue.

  7. mstaretorp
    Member
    Posted 5 months ago #

    Our host has given us problems with email before so I'll check on that.

    UPDATE: Turns out we already have an SMTP plugin. The test email won't send, so does that point to the host being the problem?

  8. Nick Ciske
    Member
    Plugin Author

    Posted 5 months ago #

    If the test email won't send, it's either your host or your settings (or a combo of the 2) ;-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.