WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Error Message when publishing a post (7 posts)

  1. jaydokie
    Member
    Posted 1 year ago #

    I get the following error when I create and publish a new post:

    Failed posting to your Facebook Timeline. Error: {"message":"(#100) You haven't enabled Explicitly Shared for this action type (331247406956072) yet. Please update your Open Graph settings in the App Dashboard","type":"OAuthException"}

    It has been working without the error message. I disabled Facebook yesterday and after troubleshooting my ad banners, I reactivated Facebook plugin and the issue started sometime after that. It still posts the article to my Facebook page RoundHouseTalk (page of news feed/timeline for jaydokie. But the error message is distracting.

    http://wordpress.org/extend/plugins/facebook/

  2. Niall Kennedy
    Member
    Plugin Author

    Posted 1 year ago #

    you have a publish action type for your application but have not yet submitted a request for explicit sharing permissions for the action.
    https://developers.facebook.com/wordpress/#author-og-setup

  3. jaydokie
    Member
    Posted 1 year ago #

    I really struggle with this open graph stuff and I've only been managing a site, my own, since last fall so I'm still new. I've read the helps but because I don't really understand, I never get it right. I only want to post to my RoundHouseTalk page which is subordinate to my personal FB news feed at jaydokie. Don't want it to post on my news feed at jaydokie which it doesn't presently. Then I want others to be able to share my post articles at http://roundhousetalk.com. I want visitors to be able to login to make comments using their FB username. Am I on the right track? Could you simplify to me how to publish the action type (what action, what do I do with the "Get Code" button, etc.)? Would really appreciate it. Thanks.

  4. jaydokie
    Member
    Posted 1 year ago #

    BTW, here is a paste of an email I received for my previous apps settings change: (the X's in the e-mail list my app id and of course 0 I replaced my IP address)

    App settings for RoundHouseTalk (app id = xxxxxxxxxxxxxxx) changed by Jay Daniels from 00.000.000.000 on Tue, 19 Feb 2013 12:59:45 -0800
    Changed settings:
    Old Value New Value
    Action Type Writedd:
    name Writedd
    singular_present is writedding
    plural_present are writedding
    singular_past writedded
    plural_past writedded
    button_text Writedd
    app_preposition on
    graph_api_name writedd
    imperative writedd
    app_id 335473406565573
    type 810
    oid 354961824616731

  5. jaydokie
    Member
    Posted 1 year ago #

    Any suggestions on this issue?

  6. jaydokie
    Member
    Posted 1 year ago #

    Looks like it's resolved but I didn't do anything since my last post. So for now I guess it's resolved.

  7. Hollosch
    Member
    Posted 1 year ago #

    How to
    "submit a request for explicit sharing permissions for the action."

    thx

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic