WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Error message when activating (6 posts)

  1. Bart van Poll
    Member
    Posted 3 years ago #

    I'm using Multi user installation and latest version of plugin.

    On all blogs, the WordPress SEO plugin works great!

    When I create a new blog though, I get many errors when the plugin is activated.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in .../wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 540

  2. gregfielding
    Member
    Posted 2 years ago #

    Getting this as well, along with errors adding widgets in new blogs. Do you get those errors as well?

  3. richstrauss
    Member
    Posted 2 years ago #

    Hello, I am getting many errors too. I created a new site (subfolder) on a multisite installation yesterday and errors aare all over. On the dashboard of my new site I get things like:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/richardt/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 540

    Fatal error: Cannot unset string offsets in /home/richardt/public_html/wp-content/plugins/wordpress-seo/wp-seo.php on line 90

    Fatal error: Cannot unset string offsets in /home/richardt/public_html/wp-content/plugins/wordpress-seo/wp-seo.php on line 90

    and then this one consistently at the top of my admin backend:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/richardt/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 540

    I have tried deactivating WordPress SEO, deleting and re-installing.

    I am running WordPress SEO Version 0.4.2 on WordPress version 3.2.1

  4. richstrauss
    Member
    Posted 2 years ago #

    Also, when I try to update a post, it wont let me, I get the following:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/richardt/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 540

    Warning: Cannot modify header information - headers already sent by (output started at /home/richardt/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php:540) in /home/richardt/public_html/wp-includes/pluggable.php on line 934

    Oh, and I have tried turning off network activation and turning it on per site too. Doesn't work.

    Thanks!

  5. Dan
    Member
    Posted 2 years ago #

    I'm getting a similar same error:

    Warning: in_array() expects parameter 2 to be array, string given in /public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 538

    Anybody got anywhere with this yet?

    It disappears if I disable XML sitemaps, but obviously I don't want to do that.

  6. Bart van Poll
    Member
    Posted 2 years ago #

    I still get the same error. Disabling XML Sitemaps is also not a solution for me. This is the error message I get:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/spotted/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 540

    Warning: Cannot modify header information - headers already sent by (output started at /home/spotted/public_html/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php:540) in /home/spotted/public_html/wp-includes/pluggable.php on line 934

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic